summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-07-14 19:58:39 -0700
committerBenjamin Denhartog2020-07-14 20:15:40 -0700
commit8f2cc2947486dfbbb2d38bbb7c1d8cc4e201cb45 (patch)
tree3261ca6261ad20f2804f91d83ab1e74cb1a8982a
parent2185583b08e7906a73006036206fbf7c37ec608b (diff)
downloadaur-8f2cc2947486dfbbb2d38bbb7c1d8cc4e201cb45.tar.gz
refactor(terragrunt): use -modcacherw instead of chmod
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec638ea9f439..be689c9a46d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = terragrunt
pkgdesc = A thin wrapper for Terraform that provides extra tools for working with multiple Terraform modules
pkgver = 0.23.31
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/gruntwork-io/terragrunt
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 58997c3065ac..759b27c58d7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=terragrunt
pkgver=0.23.31
-pkgrel=4
+pkgrel=5
pkgdesc="A thin wrapper for Terraform that provides extra tools for working with multiple Terraform modules"
url="https://github.com/gruntwork-io/terragrunt"
arch=('x86_64')
@@ -27,19 +27,11 @@ build() {
# Build the executable
# Use `-trimpath` to avoid including file system paths in the executable
go build \
+ -modcacherw \
-trimpath \
-ldflags "-X github.com/gruntwork-io/terragrunt.VERSION=${pkgver}" \
-o "${pkgname}-${pkgver}" \
main.go
-
- # Change the file mode of modules to allow them to be removed via `--clean`
- # and `--cleanbuild` options to makepkg, as well as other file-level
- # operations which attempt to delete the files. This is a hacky way to
- # accomplish this; the other option being to invoke `go clean`.
- #
- # Invoking `go clean` has the downside of removing all modules at call time,
- # which prevent re-using the module cache between builds of this package.
- chmod u+w -R "${GOPATH}/pkg/mod"
}
package() {