summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-07-14 19:39:07 -0700
committerBenjamin Denhartog2020-07-14 19:39:07 -0700
commita569dcb130e92dbc08267b1dcb10f0d24282800c (patch)
treebf6084ff5f4f07e2297201f6d9abec039ae59d02
parent3bd5357f4786dc53107faf78a793ddf46758220e (diff)
downloadaur-a569dcb130e92dbc08267b1dcb10f0d24282800c.tar.gz
chore(terragrunt): add useful comments
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e619d782b65..ec1c0a840e0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,11 @@ sha256sums=('7bb9859fd968220bcae1908079448834a789fca03d644d405a61441cd4a655a2')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ # Set GOPATH to a path within $srcdir so that we don't pollute user's $GOPATH
+ # (default of $HOME/go) when building this package
export GOPATH="${srcdir}/.go"
+ # Build the executable
go build \
-ldflags "-X github.com/gruntwork-io/terragrunt.VERSION=${pkgver}" \
-o "${pkgname}-${pkgver}" \