summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-07-14 19:42:19 -0700
committerBenjamin Denhartog2020-07-14 19:42:19 -0700
commita9a163a83ab6c5ce5b9f33501b8b35e8bd74e9f9 (patch)
treea237ab168dc55de43a173aa207fafa0402c605c4
parenta569dcb130e92dbc08267b1dcb10f0d24282800c (diff)
downloadaur-a9a163a83ab6c5ce5b9f33501b8b35e8bd74e9f9.tar.gz
feat(terragrunt): build using -trimpath to avoid including system paths in the executable
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3de8dcb69dc..850b5efbc544 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = terragrunt
pkgdesc = A thin wrapper for Terraform that provides extra tools for working with multiple Terraform modules
pkgver = 0.23.31
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gruntwork-io/terragrunt
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index ec1c0a840e0e..e123b1123d9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=terragrunt
pkgver=0.23.31
-pkgrel=2
+pkgrel=3
pkgdesc="A thin wrapper for Terraform that provides extra tools for working with multiple Terraform modules"
url="https://github.com/gruntwork-io/terragrunt"
arch=('x86_64')
@@ -25,7 +25,9 @@ build() {
export GOPATH="${srcdir}/.go"
# Build the executable
+ # Use `-trimpath` to avoid including file system paths in the executable
go build \
+ -trimpath \
-ldflags "-X github.com/gruntwork-io/terragrunt.VERSION=${pkgver}" \
-o "${pkgname}-${pkgver}" \
main.go