summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorilmikko2017-04-21 11:56:15 +0100
committerilmikko2017-04-21 11:56:15 +0100
commit83456a030ed7bdf078393ca261349d72c1993537 (patch)
treebbb587dcfab3082d1d1e5b4a23e0242fb20731ea
parent3f0a785eaeeb1613e3d961aa577eef2e77d839db (diff)
downloadaur-83456a030ed7bdf078393ca261349d72c1993537.tar.gz
Upgraded to 1.3.5.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD38
-rw-r--r--config.txt13
3 files changed, 44 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3dca2ab72f8..efa480f6ad43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = terraria-server
pkgdesc = Official dedicated server for Terraria
- pkgver = 1.3.4.4
- pkgrel = 18
+ pkgver = 1.3.5.1
+ pkgrel = 19
url = https://terraria.org/
install = terraria-server.install
arch = x86_64
@@ -10,13 +10,13 @@ pkgbase = terraria-server
makedepends = unzip
depends = mono
depends = screen
- source = http://terraria.org/server/terraria-server-1344.zip
+ source = http://terraria.org/server/terraria-server-1351.zip
source = terraria-server
source = config.txt
source = terraria-server@.service
- sha256sums = ef95d59c921e36766cbbd3a36a7494e88bb9cd47454942a84adf59050905a0dd
+ sha256sums = 16bc7b75bc4eb7478528a9d2788ca948165b83419fbc787d1273a9ff2f613559
sha256sums = 100b68ee3b88e7b095d23cd9d56e9480b21788b5165ebbf752c16b19693299f7
- sha256sums = 3823fcecd3c9d4144167c30e69f69c39c6b17d75bd40dc0abe7dc88f0d4b28cb
+ sha256sums = 6a87f9f758811528913fa4828667b200ab7dcb6623734475ecbd8f8dab337b2f
sha256sums = 24478cfa6e4e21066454ab47a7748c49d6a07d644bfb740d9c284275d6428e3a
pkgname = terraria-server
diff --git a/PKGBUILD b/PKGBUILD
index 30102ec7276f..b5e2ea20dceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainers: Mike Cooper <mythmon at elem.us>, Mikko <mikko at 5x.fi>
pkgname=terraria-server
-pkgver=1.3.4.4
-pkgrel=18
+pkgver=1.3.5.1
+pkgrel=19
pkgdesc="Official dedicated server for Terraria"
arch=('x86_64' 'x86')
license=('unknown')
@@ -18,24 +18,46 @@ source=("http://terraria.org/server/${pkgname}-${_pkgver}.zip"
'config.txt'
'terraria-server@.service')
-sha256sums=('ef95d59c921e36766cbbd3a36a7494e88bb9cd47454942a84adf59050905a0dd'
+sha256sums=('16bc7b75bc4eb7478528a9d2788ca948165b83419fbc787d1273a9ff2f613559'
'100b68ee3b88e7b095d23cd9d56e9480b21788b5165ebbf752c16b19693299f7'
- '3823fcecd3c9d4144167c30e69f69c39c6b17d75bd40dc0abe7dc88f0d4b28cb'
+ '6a87f9f758811528913fa4828667b200ab7dcb6623734475ecbd8f8dab337b2f'
'24478cfa6e4e21066454ab47a7748c49d6a07d644bfb740d9c284275d6428e3a')
package() {
unzip -o "${pkgname}-${_pkgver}.zip"
- cd 'Dedicated Server/Linux'
+ cd 'Linux'
dest="${pkgdir}/etc/terraria-server"
install -o 697 -g 697 -d "${dest}"
+
install -m644 FNA.dll "${dest}/"
install -m644 FNA.dll.config "${dest}/"
- install -m644 Ionic.Zip.CF.dll "${dest}/"
- install -m644 Steamworks.NET.dll "${dest}/"
- install -m644 Newtonsoft.Json.dll "${dest}/"
+
+ install -m644 Mono.Posix.dll "${dest}/"
+ install -m644 Mono.Security.dll "${dest}/"
+
+ install -m644 monoconfig "${dest}/"
+ install -m644 monomachineconfig "${dest}/"
+ install -m644 mscorlib.dll "${dest}/"
+ install -m644 open-folder "${dest}/"
+
+ install -m644 System.Configuration.dll "${dest}/"
+ install -m644 System.Core.dll "${dest}/"
+ install -m644 System.Data.dll "${dest}/"
+ install -m644 System.dll "${dest}/"
+ install -m644 System.Drawing.dll "${dest}/"
+ install -m644 System.Numerics.dll "${dest}/"
+ install -m644 System.Runtime.Serialization.dll "${dest}/"
+ install -m644 System.Security.dll "${dest}/"
+ install -m644 System.Windows.Forms.dll "${dest}/"
+ install -m644 System.Windows.Forms.dll.config "${dest}/"
+ install -m644 System.Xml.dll "${dest}/"
+ install -m644 System.Xml.Linq.dll "${dest}/"
+
install -m644 TerrariaServer.exe "${dest}/"
install -m755 TerrariaServer.bin.${CARCH} "${dest}/"
+ install -m644 WindowsBase.dll "${dest}/"
+
cd "${srcdir}"
install -d "${pkgdir}/usr/bin/"
install -m755 terraria-server "${pkgdir}/usr/bin/"
diff --git a/config.txt b/config.txt
index 7fbad7a56f1a..1ef4ae6572e9 100644
--- a/config.txt
+++ b/config.txt
@@ -18,16 +18,20 @@
#-forcepriority <priority> Sets the process priority for this task. If this is used the "priority" setting below will be ignored.
#-disableannouncementbox Disables the text announcements Announcement Box makes when pulsed from wire.
#-announcementboxrange <number> Sets the announcement box text messaging range in pixels, -1 for serverwide announcements.
+#-seed <seed> Specifies the world seed when using -autocreate
#remove the # in front of commands to enable them.
#Load a world and automatically start the server.
-#Make sure to set the correct permissions - the folder needs to be owned and writable by 'terraria', otherwise the server will crash!
+#Make sure to set the correct permissions - the folder needs to be writable by the user that runs the server, otherwise the server will crash!
#world=/srv/terraria/world1.wld
#Creates a new world if none is found. World size is specified by: 1(small), 2(medium), and 3(large).
#autocreate=1
+#Sets the world seed when using autocreate
+#seed=AwesomeSeed
+
#Sets the name of the world when using autocreate
#worldname=Terraria
@@ -44,7 +48,7 @@
#password=p@55w0rd
#Set the message of the day
-#motd=Please don’t cut the purple trees!
+#motd=Please don�t cut the purple trees!
#Sets the folder where world files will be stored
#worldpath=/srv/terraria/
@@ -55,8 +59,9 @@
#Adds addition cheat protection.
#secure=1
-#Sets the server language 1:English, 2:German, 3:Italian, 4:French, 5:Spanish
-#lang=1
+#Sets the server language from its language code.
+#English = en-US, German = de-DE, Italian = it-IT, French = fr-FR, Spanish = es-ES, Russian = ru-RU, Chinese = zh-Hans, Portuguese = pt-BR, Polish = pl-PL,
+#language=en-US
#Automatically forward ports with uPNP
#upnp=1