summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2021-08-11 16:20:34 -0500
committerHurricanePootis2021-08-11 16:20:34 -0500
commit281e801e60590f3a36aaf958c19cfeb20ca457d2 (patch)
treee1874833656137ebfb69c6d4daaeb3bd04f5bbc0
parentc81a3f9d7c6fa8af734765371b067e70f117f1e9 (diff)
downloadaur-281e801e60590f3a36aaf958c19cfeb20ca457d2.tar.gz
Swaggified the build process
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93431cc073ff..5cf1e863fce9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = terri-fried-git
pkgdesc = A multi-platform C++ game made for Ludum Dare 46
pkgver = r34.463aa1e
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/polymarsdev/terri-fried
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 74e217f101ea..e2158c9f70b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
pkgname=terri-fried-git
pkgver=r34.463aa1e
-pkgrel=5
+pkgrel=6
pkgdesc="A multi-platform C++ game made for Ludum Dare 46"
arch=('any')
url="https://github.com/polymarsdev/terri-fried"
@@ -19,10 +19,11 @@ pkgver() {
build() {
cd "$srcdir/terri-fried-git/windows/raylib"
- g++ -c -o player.o $CXXFLAGS player.cpp
- g++ -c -o platform.o $CXXFLAGS platform.cpp
- g++ -c -o main.o $CXXFLAGS main.cpp
- g++ -o terri-fried player.o platform.o main.o -lraylib
+ CXX=g++
+ $CXX -c -o player.o $CXXFLAGS player.cpp
+ $CXX -c -o platform.o $CXXFLAGS platform.cpp
+ $CXX -c -o main.o $CXXFLAGS main.cpp
+ $CXX -o terri-fried player.o platform.o main.o -lraylib
}
package() {