diff options
author | zxp19821005 | 2024-03-18 19:22:26 +0800 |
---|---|---|
committer | zxp19821005 | 2024-03-18 19:22:26 +0800 |
commit | 51b9cf75e38db4f0e4f1f9646772f818a0fb8fe3 (patch) | |
tree | d621285cb21f8cc67f3b6f2f954b935cfb100e1a | |
parent | 25dc24eb7e8dc407ffc29449a02b721b9063ade9 (diff) | |
download | aur-51b9cf75e38db4f0e4f1f9646772f818a0fb8fe3.tar.gz |
fix errors
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 8 | ||||
-rw-r--r-- | tesler.sh | 8 |
3 files changed, 14 insertions, 7 deletions
@@ -1,10 +1,11 @@ pkgbase = tesler-bin pkgdesc = TesLEr - The Tesla Sentinel Viewer pkgver = 0.2.3 - pkgrel = 6 + pkgrel = 7 url = https://github.com/j-catania/TeslaSentinelViewer arch = x86_64 license = MIT + makedepends = fuse2 depends = electron22 depends = hicolor-icon-theme provides = tesler=0.2.3 @@ -14,6 +15,6 @@ pkgbase = tesler-bin source = tesler.sh sha256sums = 5447e01520ad757fdbb4130e764a863c9d282c5dd48cf2fabbd33e171a2decfd sha256sums = 29eee3e9d9c5dd67213ec3ab4a7eef57a1224750e2e9aab3a278177a9444a355 - sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014 + sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8 pkgname = tesler-bin @@ -3,7 +3,7 @@ pkgname=tesler-bin _pkgname=TesLEr pkgver=0.2.3 _electronversion=22 -pkgrel=6 +pkgrel=7 pkgdesc="TesLEr - The Tesla Sentinel Viewer" arch=('x86_64') url="https://github.com/j-catania/TeslaSentinelViewer" @@ -14,6 +14,9 @@ depends=( "electron${_electronversion}" 'hicolor-icon-theme' ) +makedepends=( + 'fuse2' +) source=( "${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/v${pkgver}/TesLEr-${pkgver}.AppImage" "LICENSE-${pkgver}::https://raw.githubusercontent.com/j-catania/TeslaSentinelViewer/v${pkgver}/LICENSE" @@ -21,11 +24,12 @@ source=( ) sha256sums=('5447e01520ad757fdbb4130e764a863c9d282c5dd48cf2fabbd33e171a2decfd' '29eee3e9d9c5dd67213ec3ab4a7eef57a1224750e2e9aab3a278177a9444a355' - '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014') + 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8') build() { sed -e "s|@electronversion@|${_electronversion}|" \ -e "s|@appname@|${pkgname%-bin}|g" \ -e "s|@runname@|app.asar|g" \ + -e "s|@options@||g" \ -i "${srcdir}/${pkgname%-bin}.sh" chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null diff --git a/tesler.sh b/tesler.sh index f9ced1432cfc..7ddcaab8d734 100644 --- a/tesler.sh +++ b/tesler.sh @@ -1,14 +1,16 @@ -#!/bin/sh +#!/bin/bash set -e _APPDIR="/usr/lib/@appname@" _RUNNAME="${_APPDIR}/@runname@" +_OPTIONS="@options@" export PATH="${_APPDIR}:${PATH}" export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}" export ELECTRON_IS_DEV=0 +export ELECTRON_FORCE_IS_PACKAGED=true export NODE_ENV=production cd "${_APPDIR}" if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then - exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $? + exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $? else - exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $? + exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $? fi
\ No newline at end of file |