summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsquitch2021-09-02 07:13:04 +0000
committersquitch2021-09-02 07:13:04 +0000
commit9cc2d50608bb7ec4c5e5a722676f46ca8b5616d2 (patch)
tree51edec471de29d129805ee96a8edc416ff6d2334
parentaa1461fd439e7ef7aab99166d988e08fcbf4597f (diff)
downloadaur-9cc2d50608bb7ec4c5e5a722676f46ca8b5616d2.tar.gz
Update AUR package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e3ba6ba48926..8d10528f134c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = tess-git
- pkgdesc = Hackable, simple, rapid and beautiful terminal for the new era
- pkgver = 0.4.2.r1.g12ee207
+ pkgdesc = Tess hackable, simple, rapid and beautiful terminal for the new era
+ pkgver = 0.4.2.r58.g1ebfce0
pkgrel = 1
- epoch = 1
- url = https://github.com/SquitchYT/Tess
+ url = https://github.com/SquitchYT/Tess.git
arch = x86_64
- license = MPL2
+ license = unknown
makedepends = git
makedepends = npm
+ depends = glib2
+ depends = glibc
depends = gtk3
- depends = nss
source = git+https://github.com/SquitchYT/Tess.git
- sha256sums = SKIP
+ md5sums = SKIP
pkgname = tess-git
diff --git a/PKGBUILD b/PKGBUILD
index e4a41041ed97..87e459778512 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,14 @@
-# Maintainer:
-# Contributor: FabioLolix
-# COntributor: squitch
-
pkgname=tess-git
-pkgver=0.4.2.r1.g12ee207
+pkgver=0.4.2.r58.g1ebfce0
pkgrel=1
-epoch=1
-pkgdesc="Hackable, simple, rapid and beautiful terminal for the new era"
+pkgdesc="Tess hackable, simple, rapid and beautiful terminal for the new era"
arch=(x86_64)
-url="https://github.com/SquitchYT/Tess"
-license=(MPL2)
-depends=(gtk3 nss)
-makedepends=(git npm)
-source=("git+https://github.com/SquitchYT/Tess.git")
-sha256sums=('SKIP')
+url="https://github.com/SquitchYT/Tess.git"
+license=('unknown')
+depends=("glib2" "glibc" "gtk3")
+makedepends=("git" "npm")
+source=("git+$url")
+md5sums=("SKIP")
pkgver() {
cd "Tess"
@@ -22,9 +17,10 @@ pkgver() {
package() {
cd "Tess"
-
+
install -D Tess.desktop "${pkgdir}/usr/share/applications/Tess.desktop"
install -D tesshere.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/tesshere.desktop"
+ install -D appintess.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/appintess.desktop"
if type "$kbuildsycoca5" > /dev/null; then
kbuildsycoca5
@@ -33,7 +29,7 @@ package() {
mkdir -p "${pkgdir}/opt/tess-cli"
mkdir -p "${pkgdir}/usr/bin"
- cp "./src/img/Tess.png" "${pkgdir}/usr/bin/Tess.png"
+ cp "./src/img/Tess.png" "${pkgdir}/usr/bin/Tess.png"
cd "cli"
g++ main.cpp Class/*.cpp Utils/*.cpp Lib/*.cpp Lib/external/cpr/cpr/*.cpp -lpthread -lcurl -std=c++17 -o tess-cli