summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsquitch2021-09-10 17:45:42 +0000
committersquitch2021-09-10 17:45:42 +0000
commita8d47faa63ca4872f5ed795586f118755f9a1974 (patch)
tree35b978b7c620d0b4fddf5d342be2f8bbf9a0f71b
parentf7c000732887d51c896c130b3166b23f78588d24 (diff)
downloadaur-a8d47faa63ca4872f5ed795586f118755f9a1974.tar.gz
Update AUR package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a952a1a071bf..92e0b13ea89f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tess-git
pkgdesc = Hackable, simple, rapid and beautiful terminal for the new era
- pkgver = 0.4.3.r5.gb1592e0
+ pkgver = 0.4.3.r40.g36f0244
pkgrel = 1
epoch = 1
url = https://github.com/SquitchYT/Tess
@@ -9,10 +9,8 @@ pkgbase = tess-git
makedepends = git
makedepends = npm
makedepends = cmake
- makedepends = chrpath
depends = gtk3
depends = nss
- depends = cpr
source = git+https://github.com/SquitchYT/Tess.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e4648ffaecb2..ba975fa85998 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Maintainer: squitch
pkgname=tess-git
-pkgver=0.4.3.r5.gb1592e0
+pkgver=0.4.3.r40.g36f0244
pkgrel=1
epoch=1
pkgdesc="Hackable, simple, rapid and beautiful terminal for the new era"
arch=(x86_64)
url="https://github.com/SquitchYT/Tess"
license=(MPL2)
-depends=(gtk3 nss cpr)
-makedepends=(git npm cmake chrpath)
+depends=(gtk3 nss)
+makedepends=(git npm cmake)
source=("git+https://github.com/SquitchYT/Tess.git")
sha256sums=('SKIP')
@@ -24,18 +24,16 @@ package() {
install -D Tess.desktop "${pkgdir}/usr/share/applications/Tess.desktop"
install -D tesshere.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/tesshere.desktop"
install -D appintess.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/appintess.desktop"
- install -D src/img/Tess.png "${pkgdir}/usr/share/pixmaps/tess.png"
+ install -D build/icon.png "${pkgdir}/usr/share/pixmaps/tess.png"
if type "$kbuildsycoca5" > /dev/null; then
kbuildsycoca5
fi
cd cli
- mkdir -p build
- cmake -S . -B build
+ cmake . -B build
make -C build
install -Dm755 build/tess-cli -t "${pkgdir}/usr/bin/"
- chrpath --delete "${pkgdir}/usr/bin/tess-cli"
npm install
npm run build