summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-09-01 19:00:20 +0200
committerFabioLolix2021-09-01 19:00:20 +0200
commitaa1461fd439e7ef7aab99166d988e08fcbf4597f (patch)
treeaa3f39c734feeb6993960160f31b4a6912c88e10
parent7c36944c339706a067e6ef1076161772e62fe3d6 (diff)
downloadaur-aa1461fd439e7ef7aab99166d988e08fcbf4597f.tar.gz
revision
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19d53127b064..e3ba6ba48926 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = tess-git
- pkgdesc = Tess hackable, simple, rapid and beautiful terminal for the new era
- pkgver = 1.2r234.c480fcf
+ pkgdesc = Hackable, simple, rapid and beautiful terminal for the new era
+ pkgver = 0.4.2.r1.g12ee207
pkgrel = 1
- url = https://github.com/SquitchYT/Tess.git
+ epoch = 1
+ url = https://github.com/SquitchYT/Tess
arch = x86_64
- license = unknown
+ license = MPL2
makedepends = git
makedepends = npm
- depends = glib2
- depends = glibc
+ depends = gtk3
+ depends = nss
source = git+https://github.com/SquitchYT/Tess.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = tess-git
diff --git a/PKGBUILD b/PKGBUILD
index 0b805340b10d..e4a41041ed97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
+# Maintainer:
+# Contributor: FabioLolix
+# COntributor: squitch
+
pkgname=tess-git
-pkgver=1.2r234.c480fcf
+pkgver=0.4.2.r1.g12ee207
pkgrel=1
-pkgdesc="Tess hackable, simple, rapid and beautiful terminal for the new era"
+epoch=1
+pkgdesc="Hackable, simple, rapid and beautiful terminal for the new era"
arch=(x86_64)
-url="https://github.com/SquitchYT/Tess.git"
-license=('unknown')
-depends=('glib2' 'glibc')
-makedepends=('git' 'npm')
-source=("git+$url")
-md5sums=('SKIP')
+url="https://github.com/SquitchYT/Tess"
+license=(MPL2)
+depends=(gtk3 nss)
+makedepends=(git npm)
+source=("git+https://github.com/SquitchYT/Tess.git")
+sha256sums=('SKIP')
pkgver() {
cd "Tess"
- printf "1.2r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
cd "Tess"
- mkdir -p "${pkgdir}/usr/share/applications"
- cp -r -f Tess.desktop "${pkgdir}/usr/share/applications/Tess.desktop"
-
- mkdir -p "${pkgdir}/usr/share/kservices5/ServiceMenus/"
- cp -r -f tesshere.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/tesshere.desktop"
+ install -D Tess.desktop "${pkgdir}/usr/share/applications/Tess.desktop"
+ install -D tesshere.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/tesshere.desktop"
if type "$kbuildsycoca5" > /dev/null; then
kbuildsycoca5
@@ -50,4 +52,4 @@ package() {
cp -r -f * "${pkgdir}/opt/tess/"
ln -s "/opt/tess/tess" "${pkgdir}/usr/bin/tess"
-} \ No newline at end of file
+}