summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-09-04 21:42:47 +0200
committerFabioLolix2021-09-04 21:42:47 +0200
commitf7c000732887d51c896c130b3166b23f78588d24 (patch)
tree510cb78101ec75de59e2078981aea1c0856b57c6
parent59343780ef77414bddc2e12fa736f1d4d1f784f8 (diff)
downloadaur-f7c000732887d51c896c130b3166b23f78588d24.tar.gz
update deps
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD54
2 files changed, 30 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a555e6147a..a952a1a071bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tess-git
pkgdesc = Hackable, simple, rapid and beautiful terminal for the new era
- pkgver = 0.4.3.r1.g4911a38
+ pkgver = 0.4.3.r5.gb1592e0
pkgrel = 1
epoch = 1
url = https://github.com/SquitchYT/Tess
@@ -9,8 +9,10 @@ pkgbase = tess-git
makedepends = git
makedepends = npm
makedepends = cmake
+ makedepends = chrpath
depends = gtk3
depends = nss
+ depends = cpr
source = git+https://github.com/SquitchYT/Tess.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 10a326521834..e4648ffaecb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Maintainer: squitch
pkgname=tess-git
-pkgver=0.4.3.r1.g4911a38
+pkgver=0.4.3.r5.gb1592e0
pkgrel=1
epoch=1
pkgdesc="Hackable, simple, rapid and beautiful terminal for the new era"
arch=(x86_64)
url="https://github.com/SquitchYT/Tess"
license=(MPL2)
-depends=(gtk3 nss)
-makedepends=(git npm cmake)
+depends=(gtk3 nss cpr)
+makedepends=(git npm cmake chrpath)
source=("git+https://github.com/SquitchYT/Tess.git")
sha256sums=('SKIP')
@@ -20,28 +20,28 @@ pkgver() {
}
package() {
- cd "Tess"
-
- install -D Tess.desktop "${pkgdir}/usr/share/applications/Tess.desktop"
- install -D tesshere.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/tesshere.desktop"
- install -D appintess.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/appintess.desktop"
- install -D src/img/Tess.png "${pkgdir}/usr/share/pixmaps/tess.png"
-
- if type "$kbuildsycoca5" > /dev/null; then
- kbuildsycoca5
- fi
-
- cd cli
- mkdir -p build
- cmake -S . -B build
- make -C build
- install -Dm755 build/tess-cli -t "${pkgdir}/usr/bin/"
-
- npm install
- npm run build
-
- mkdir -p "${pkgdir}/opt/tess"
- cd ../dist/linux-unpacked
- cp -r -f * "${pkgdir}/opt/tess/"
- ln -s "/opt/tess/tess" "${pkgdir}/usr/bin/tess"
+ cd "Tess"
+ install -D Tess.desktop "${pkgdir}/usr/share/applications/Tess.desktop"
+ install -D tesshere.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/tesshere.desktop"
+ install -D appintess.desktop "${pkgdir}/usr/share/kservices5/ServiceMenus/appintess.desktop"
+ install -D src/img/Tess.png "${pkgdir}/usr/share/pixmaps/tess.png"
+
+ if type "$kbuildsycoca5" > /dev/null; then
+ kbuildsycoca5
+ fi
+
+ cd cli
+ mkdir -p build
+ cmake -S . -B build
+ make -C build
+ install -Dm755 build/tess-cli -t "${pkgdir}/usr/bin/"
+ chrpath --delete "${pkgdir}/usr/bin/tess-cli"
+
+ npm install
+ npm run build
+
+ mkdir -p "${pkgdir}/usr/lib/tess"
+ cd ../dist/linux-unpacked
+ cp -r -f * "${pkgdir}/usr/lib/tess/"
+ ln -s "/usr/lib/tess/tess" "${pkgdir}/usr/bin/tess"
}