summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAyush Agarwal2021-11-14 19:30:03 +0530
committerAyush Agarwal2021-11-14 19:30:03 +0530
commit17ef08771e0c2f50bc088e1021d1fb94e3f5e285 (patch)
treeaf02865b556af52bb0a0bca5f84f20ddc41d1695
parentaf3efdf6cde9ee8443d11e81d645cfcef4b6cb11 (diff)
downloadaur-17ef08771e0c2f50bc088e1021d1fb94e3f5e285.tar.gz
release: update tessen to v1.2.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
-rw-r--r--tessen.install4
3 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b377d04a4c29..76fbcf95a597 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = tessen
pkgdesc = An interactive menu to autotype and copy password-store data
- pkgver = 1.1.1
+ pkgver = 1.2.1
pkgrel = 1
url = https://github.com/ayushnix/tessen
+ install = tessen.install
arch = x86_64
license = GPL
+ makedepends = scdoc
depends = pass
- depends = bemenu
depends = wtype
depends = wl-clipboard
- depends = libnotify
+ optdepends = libnotify: to send notifications about copied data
+ optdepends = bemenu: wayland native dmenu backend
optdepends = rofi-lbonn-wayland-git: the wayland native fork of rofi
optdepends = wofi: unmaintained gtk based backend
+ optdepends = xdg-utils: to open URLs in default web browser
conflicts = tessen-git
- source = tessen-1.1.1.tar.gz::https://github.com/ayushnix/tessen/archive/refs/tags/v1.1.1.tar.gz
- sha256sums = 30671b4e9333d7f61ff39f671c67ac9dfef38e500e14accf131cfdd1c9df9ffe
+ source = tessen-1.2.1.tar.gz::https://github.com/ayushnix/tessen/archive/refs/tags/v1.2.1.tar.gz
+ sha256sums = 535f911d629d26738d3e298425cb2bb53f1ae7b8a7e833e8b845b2dba9eaac21
pkgname = tessen
diff --git a/PKGBUILD b/PKGBUILD
index f7ff122451da..c39f27d5fbb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
# Maintainer: Ayush Agarwal <ayush at fastmail dot in>
pkgname=tessen
-pkgver=1.1.1
-_pkgver=1.1.1
+pkgver=1.2.1
pkgrel=1
pkgdesc="An interactive menu to autotype and copy password-store data"
arch=(x86_64)
url="https://github.com/ayushnix/tessen"
license=('GPL')
depends=('pass'
- 'bemenu'
'wtype'
- 'wl-clipboard'
- 'libnotify')
-optdepends=('rofi-lbonn-wayland-git: the wayland native fork of rofi'
- 'wofi: unmaintained gtk based backend')
+ 'wl-clipboard')
+makedepends=('scdoc')
+optdepends=('libnotify: to send notifications about copied data'
+ 'bemenu: wayland native dmenu backend'
+ 'rofi-lbonn-wayland-git: the wayland native fork of rofi'
+ 'wofi: unmaintained gtk based backend'
+ 'xdg-utils: to open URLs in default web browser')
conflicts=('tessen-git')
-source=("$pkgname-$_pkgver.tar.gz::https://github.com/ayushnix/tessen/archive/refs/tags/v${_pkgver}.tar.gz")
-sha256sums=('30671b4e9333d7f61ff39f671c67ac9dfef38e500e14accf131cfdd1c9df9ffe')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ayushnix/tessen/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('535f911d629d26738d3e298425cb2bb53f1ae7b8a7e833e8b845b2dba9eaac21')
+install=tessen.install
package() {
cd "$pkgname-$pkgver"
diff --git a/tessen.install b/tessen.install
new file mode 100644
index 000000000000..aa7cc0a644d9
--- /dev/null
+++ b/tessen.install
@@ -0,0 +1,4 @@
+post_install() {
+ printf "%s\n" "tessen needs either 'bemenu', 'rofi-lbonn-wayland-git', or 'wofi' to work."
+ printf "%s\n" "Please install at least one of the packages mentioned above."
+}