summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:11:24 +0100
committerSteven Honeyman2015-06-09 19:11:24 +0100
commit776dfde31b67e9cd17fa53d53ff390d96a7c42ca (patch)
treec581debed695503556a24167c3ab562aa8eddb78
downloadaur-776dfde31b67e9cd17fa53d53ff390d96a7c42ca.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c1343ba04f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = testdisk-wip
+ pkgdesc = Checks and undeletes partitions. Includes PhotoRec signature based recovery tool. WIP version
+ pkgver = 7.0
+ pkgrel = 5
+ url = http://www.cgsecurity.org/wiki/TestDisk
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libjpeg
+ optdepends = libewf: support EnCase files
+ optdepends = ntfs-3g: support NTFS partitions
+ optdepends = progsreiserfs: support ReiserFS partitions
+ optdepends = qt5-base: QPhotoRec GUI
+ provides = testdisk
+ conflicts = testdisk
+ source = http://www.cgsecurity.org/testdisk-7.0-WIP.tar.bz2
+ md5sums = SKIP
+
+pkgname = testdisk-wip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4826f80793fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=testdisk-wip
+pkgver=7.0
+pkgrel=5
+pkgdesc="Checks and undeletes partitions. Includes PhotoRec signature based recovery tool. WIP version"
+arch=('i686' 'x86_64')
+url="http://www.cgsecurity.org/wiki/TestDisk"
+license=('GPL')
+depends=('libjpeg')
+optdepends=('libewf: support EnCase files'
+ 'ntfs-3g: support NTFS partitions'
+ 'progsreiserfs: support ReiserFS partitions'
+ 'qt5-base: QPhotoRec GUI')
+conflicts=('testdisk')
+provides=('testdisk')
+source=(http://www.cgsecurity.org/testdisk-$pkgver-WIP.tar.bz2)
+#md5sums=('5d239865543019227c4ac5052066da6f')
+md5sums=('SKIP') # they update the source without changing the filename...
+
+prepare() {
+ cd "$srcdir/testdisk-$pkgver-WIP"
+
+ # Some fixes to make it Qt5 capable
+ sed -i '/<QWidget>/d' src/*.h
+ sed -i '/<QWidget>/d' src/*.cpp
+ sed -i 's/Qt::escape\(.*\)text())/QString\1text()).toHtmlEscaped()/g' src/qphotorec.cpp
+
+ ## You might not need these, but I did for some reason
+ test -f src/gnome/help-about.png || cp /usr/share/icons/gnome/48x48/actions/help-about.png src/gnome/
+ test -f src/gnome/image-x-generic.png || cp /usr/share/icons/gnome/48x48/mimetypes/image-x-generic.png src/gnome/
+}
+
+build() {
+ cd "$srcdir/testdisk-$pkgver-WIP"
+ export QTGUI_LIBS="$(pkg-config Qt5Widgets --libs)"
+ export QTGUI_CFLAGS="-fPIC $(pkg-config Qt5Widgets --cflags)"
+
+ # add --disable-qt if you do not have qt5-base
+ ./configure --prefix=/usr --enable-sudo
+ make
+}
+
+package() {
+ cd "$srcdir/testdisk-$pkgver-WIP"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: