summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Schleifenbaum2015-07-18 12:04:02 +0200
committerJohannes Schleifenbaum2015-07-18 12:04:02 +0200
commitfe997cc5cffd42fabbb086b89572c271c8c436f8 (patch)
tree2656369b6d87ef08e1cef556d326c6170bdc41c4
downloadaur-fe997cc5cffd42fabbb086b89572c271c8c436f8.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..843eb4a83a1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = testssl.sh-git
+ pkgdesc = Testing TLS/SSL encryption (git version)
+ pkgver = v2.4.r126.gcbbe7d8
+ pkgrel = 1
+ url = https://github.com/drwetter/testssl.sh
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = bash
+ depends = coreutils
+ depends = util-linux
+ depends = openssl
+ provides = testssl.sh
+ conflicts = testssl.sh
+ source = testssl.sh-git::git+https://github.com/drwetter/testssl.sh.git
+ sha256sums = SKIP
+
+pkgname = testssl.sh-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b7223765a4e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.*
+pkg/
+src/
+*.pkg.*.sig
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6b4426fd20f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Johannes Schleifenbaum <johannes [at] js-webcoding [dot] de>
+# Please report issues at https://github.com/jojosch/pkgbuilds
+
+pkgname='testssl.sh-git'
+pkgver=v2.4.r126.gcbbe7d8
+pkgrel=1
+pkgdesc="Testing TLS/SSL encryption (git version)"
+arch=('any')
+url="https://github.com/drwetter/testssl.sh"
+license=("GPL")
+depends=('bash' 'coreutils' 'util-linux' 'openssl')
+makedepends=('git')
+conflicts=('testssl.sh')
+provides=('testssl.sh')
+source=("${pkgname}::git+https://github.com/drwetter/${pkgname/-git/}.git")
+sha256sums=('SKIP')
+
+pkgver () {
+ cd "${srcdir}/${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ install -D -m755 "testssl.sh" "${pkgdir}/usr/bin/testssl.sh"
+}