summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorf41c0r2015-11-01 23:06:49 -0500
committerf41c0r2015-11-01 23:06:49 -0500
commit3d3c7514f59bb7f4b652a963c335e5d894bdd2c9 (patch)
tree71ac66fc88c0ba318de93de621abdb4482c4137d
downloadaur-3d3c7514f59bb7f4b652a963c335e5d894bdd2c9.tar.gz
Initial import of package
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa247deb3ba2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = testsslserver
+ pkgdesc = A script to test TLS/SSL servers for CRIME, BEAST, and other issues.
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.bolet.org/TestSSLServer/
+ arch = any
+ license = MIT
+ depends = java-runtime
+ noextract = testsslserver.jar
+ source = testsslserver.jar::http://www.bolet.org/TestSSLServer/TestSSLServer.jar
+ source = LICENSE
+ md5sums = ceececde5204be3eca4ee45390f854df
+ md5sums = 9e6efa0007a424c6190c5eeab78b2555
+
+pkgname = testsslserver
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..033f9509e1a5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+Copyright (c) 2012 Thomas Pornin <pornin@bolet.org>
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS
+BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN
+ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6edf011a5600
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: luckdragon <f41c0r [/at\] hack DOT ink>
+
+pkgname=testsslserver
+pkgver=1.0
+pkgrel=1
+pkgdesc="A script to test TLS/SSL servers for CRIME, BEAST, and other issues."
+url="http://www.bolet.org/TestSSLServer/"
+depends=('java-runtime')
+arch=('any')
+license=('MIT')
+noextract=("${pkgname}.jar")
+source=("${pkgname}.jar::http://www.bolet.org/TestSSLServer/TestSSLServer.jar"
+ LICENSE)
+md5sums=('ceececde5204be3eca4ee45390f854df'
+ '9e6efa0007a424c6190c5eeab78b2555')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/{${pkgname},licenses/${pkgname}}
+
+ cd ${srcdir}
+ install -m644 ${pkgname}.jar ${pkgdir}/usr/share/${pkgname}/${pkgname}.jar
+ install -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/
+
+ # Create startup file for burpsuite.
+ echo "#!/bin/sh" > ${pkgdir}/usr/bin/TestSSLServer
+ echo "exec \$JAVA_HOME/bin/java -jar /usr/share/${pkgname}/${pkgname}.jar \$@" >> ${pkgdir}/usr/bin/TestSSLServer
+ chmod +x ${pkgdir}/usr/bin/TestSSLServer
+}
+
+# vim:set ts=2 sw=2 et: