summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-01-26 14:34:37 +0100
committerhaawda2020-01-26 14:34:37 +0100
commit8aa8ee11ab388d4240b441b5055cd366c3d5da0e (patch)
tree1971f012fd1bd0d6975c1f779d1235ffd3f2fc89
parentef97c25f798c96b186132467bde6e31b13d11855 (diff)
downloadaur-8aa8ee11ab388d4240b441b5055cd366c3d5da0e.tar.gz
adopted and updated
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59f29b4d9e35..57817d1f9e1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,28 +8,26 @@ pkgdesc='A Quality Tetrahedral Mesh Generator and a 3D Delaunay Triangulator'
arch=('x86_64')
url='http://wias-berlin.de/software/index.jsp?id=TetGen&lang=1'
license=('AGPL3')
-changelog="${pkgname}.changelog"
# You must accept the licensing terms before downloading the source archive:
# http://wias-berlin.de/software/tetgen/download2.jsp
# Place the downloaded archive in $SRCDEST of your /etc/makepkg.conf
source=("local://${pkgname}${pkgver}.tar.gz")
-md5sums=('2ab470d2b3c47b9edae6febe45d7a0e1')
-
-prepare() {
- mkdir -p build
-}
+sha256sums=('e46a4434a3e7c00044c8f4f167e18b6f4a85be7d22838c8f948ce8cc8c01b850')
+options=('staticlibs')
build() {
- cd build
- cmake ../"${pkgname}${pkgver}" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release
- make
+ [[ -d build ]] && rm -rf build
+ mkdir build
+ cd build
+ cmake ../"${pkgname}${pkgver}" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
}
package() {
- cd build
- install -m 755 -D -t "${pkgdir}/usr/bin" tetgen
- install -m 644 -D -t "${pkgdir}/usr/lib" libtet.a
- install -m 644 -D -t "${pkgdir}/usr/include" ../"${pkgname}${pkgver}/tetgen.h"
+ cd build
+ install -m 755 -D -t "${pkgdir}/usr/bin" tetgen
+ install -m 644 -D -t "${pkgdir}/usr/lib" libtet.a
+ install -m 644 -D -t "${pkgdir}/usr/include" ../"${pkgname}${pkgver}/tetgen.h"
}