summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2023-01-10 13:41:02 -0500
committerGraeme Gott2023-01-10 13:41:02 -0500
commit82dc861b3bf05bc91cb23807bf7e12b767449478 (patch)
treeb71c7f3c31420709eef30395492828ce330c6a0a
parent7589094941e6fccd35108a5e8cc183fd24b30619 (diff)
downloadaur-82dc861b3bf05bc91cb23807bf7e12b767449478.tar.gz
Update to 2.2.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7495c4f9863..08f66634f9e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tetzle
- pkgdesc = A tetromino jigsaw puzzle game
- pkgver = 2.2.1
+ pkgdesc = Tetromino jigsaw puzzle game
+ pkgver = 2.2.2
pkgrel = 1
url = https://gottcode.org/tetzle/
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = tetzle
makedepends = cmake
makedepends = qt6-tools
depends = qt6-base
- source = https://gottcode.org/tetzle/tetzle-2.2.1-src.tar.bz2
- sha256sums = ca5cc2837c3a3fa959655e140821e99104b88765bfd2e777e5d6a18b3f2592d4
+ source = https://gottcode.org/tetzle/tetzle-2.2.2.tar.bz2
+ sha256sums = 284647453287752365d413e679efe572528efcc44eaf7f74f90fc9629ecfcb6b
pkgname = tetzle
diff --git a/PKGBUILD b/PKGBUILD
index c6aeb211dac9..7448613cfaa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=tetzle
-pkgver=2.2.1
+pkgver=2.2.2
pkgrel=1
-pkgdesc='A tetromino jigsaw puzzle game'
+pkgdesc='Tetromino jigsaw puzzle game'
arch=(x86_64)
-url="https://gottcode.org/$pkgname/"
+url="https://gottcode.org/${pkgname}/"
license=('GPL3')
depends=('qt6-base')
makedepends=('cmake' 'qt6-tools')
-source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('ca5cc2837c3a3fa959655e140821e99104b88765bfd2e777e5d6a18b3f2592d4')
+source=("https://gottcode.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('284647453287752365d413e679efe572528efcc44eaf7f74f90fc9629ecfcb6b')
build() {
- cmake -B build -S $pkgbase-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
cmake --build build
}