summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond W. Ko2017-10-30 16:49:04 -0400
committerRaymond W. Ko2017-10-30 16:49:04 -0400
commitc1c2b197269c6b9c3cac918fdb87a0b8ecfd02c4 (patch)
treefed425db1e1747b6822ce00f53024b7286f8c6a9
parent9c9276839f395d2a917f17bd6ebaaed0f1c2756b (diff)
downloadaur-c1c2b197269c6b9c3cac918fdb87a0b8ecfd02c4.tar.gz
fix broken build
Hmm, for some reason, the man page has disappeared!
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96aed74f208e..40293c51fed3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = tewisay-git
pkgdesc = Cowsay replacement with unicode and partial ansi escape support.
- pkgver = 0.59.cd6e1b9
- pkgrel = 3
+ pkgver = 0.65.e3fc387
+ pkgrel = 1
url = https://github.com/lucy/tewisay
arch = i686
arch = x86_64
@@ -14,10 +14,6 @@ pkgbase = tewisay-git
optdepends = cowsay: default cowfiles
options = !strip
source = git://github.com/lucy/tewisay.git
- source = git://github.com/lucy/pflag.git
- source = git://github.com/lucy/rwidth.git
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = SKIP
pkgname = tewisay-git
diff --git a/PKGBUILD b/PKGBUILD
index 29536f7bc0b3..931521ad00f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=tewisay-git
_gitname='tewisay'
_gourl='github.com/neeee/tewisay'
-pkgver=0.59.cd6e1b9
-pkgrel=3
+pkgver=0.65.e3fc387
+pkgrel=1
pkgdesc='Cowsay replacement with unicode and partial ansi escape support.'
url='https://github.com/lucy/tewisay'
license=('custom:CC0')
@@ -13,10 +13,8 @@ optdepends=('cowsay: default cowfiles')
makedepends=('go' 'git' 'asciidoc')
arch=('i686' 'x86_64' 'ARM')
options=('!strip')
-source=('git://github.com/lucy/tewisay.git'
- 'git://github.com/lucy/pflag.git'
- 'git://github.com/lucy/rwidth.git')
-sha256sums=('SKIP' 'SKIP' 'SKIP')
+source=('git://github.com/lucy/tewisay.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_gitname"
@@ -25,23 +23,18 @@ pkgver() {
prepare() {
cd "$srcdir/$_gitname"
- git config submodule.pflag.url "$srcdir/pflag"
- git config submodule.rwidth.url "$srcdir/rwidth"
- git submodule init
- git submodule update
+ go get -d ./...
}
build() {
cd "$srcdir/$_gitname"
go build
- a2x --doctype manpage --format manpage tewisay.1.txt
}
package() {
cd "$srcdir/$_gitname"
install -Dm755 -T tewisay "$pkgdir/usr/bin/tewisay"
- install -Dm644 -T _tewisay "$pkgdir/usr/share/zsh/site-functions/_tewisay"
- install -Dm644 -T tewisay.1 "$pkgdir/usr/share/man/man1/tewisay.1"
+ install -Dm644 -T zsh/_tewisay "$pkgdir/usr/share/zsh/site-functions/_tewisay"
install -Dm644 -T COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
install -Dm644 -T cows/COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING.tewis"
install -Dm755 -d "$pkgdir/usr/share/cows"