summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaymond W. Ko2022-11-04 00:07:26 -0400
committerRaymond W. Ko2022-11-04 00:07:26 -0400
commite12ca710b7d37157cff5a14414fe02a0eafa94e7 (patch)
treea1f1c38a234c6aaf01c9298a5ab83143027b4f9e
parentc1c2b197269c6b9c3cac918fdb87a0b8ecfd02c4 (diff)
downloadaur-e12ca710b7d37157cff5a14414fe02a0eafa94e7.tar.gz
move over to a mirror repo and fix build
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40293c51fed3..294b22bdf756 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = tewisay-git
pkgdesc = Cowsay replacement with unicode and partial ansi escape support.
- pkgver = 0.65.e3fc387
+ pkgver = 0.66.caa5b01
pkgrel = 1
- url = https://github.com/lucy/tewisay
+ url = https://github.com/raymond-w-ko/tewisay
arch = i686
arch = x86_64
arch = ARM
@@ -13,8 +13,7 @@ pkgbase = tewisay-git
depends = glibc
optdepends = cowsay: default cowfiles
options = !strip
- source = git://github.com/lucy/tewisay.git
+ source = git+https://github.com/raymond-w-ko/tewisay.git
sha256sums = SKIP
pkgname = tewisay-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 931521ad00f3..7761764bf32a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
-# Maintainer: lucy <lucy@luz.lu>
+# Maintainer: Raymond W. Ko <r a y m o nd DOT w DOT k o AT g m ai l DOT COM>
pkgname=tewisay-git
_gitname='tewisay'
-_gourl='github.com/neeee/tewisay'
-pkgver=0.65.e3fc387
+pkgver=0.66.caa5b01
pkgrel=1
pkgdesc='Cowsay replacement with unicode and partial ansi escape support.'
-url='https://github.com/lucy/tewisay'
+url='https://github.com/raymond-w-ko/tewisay'
license=('custom:CC0')
depends=('glibc')
optdepends=('cowsay: default cowfiles')
makedepends=('go' 'git' 'asciidoc')
arch=('i686' 'x86_64' 'ARM')
options=('!strip')
-source=('git://github.com/lucy/tewisay.git')
+source=('git+https://github.com/raymond-w-ko/tewisay.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
- echo "0.$(git rev-list --count HEAD).$(git describe --always )"
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {