summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Schlichting2015-03-16 13:49:19 +0100
committerAndré Schlichting2015-03-16 13:49:19 +0100
commit142776a55064cc4032da8c87ea87b6590cc87562 (patch)
treee01e7295bdb95039d7206eb4a1751acbcafcdc43
downloadaur-142776a55064cc4032da8c87ea87b6590cc87562.tar.gz
initial maintained aur-packages
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
-rw-r--r--support-synctex.patch27
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c0c3bdaa276
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = texbuild-git
+ pkgdesc = This small script continuously builds a latex file in the background. It only overwrites the target pdf file upon a successful and complete build allowing to continuously watch the PDF in PDF viewer.
+ pkgver = r8.e9e6369
+ pkgrel = 1
+ url = https://github.com/pbiggar/texbuild
+ arch = any
+ license = GPL
+ makedepends = git
+ source = support-synctex.patch
+ source = git+https://github.com/pbiggar/texbuild.git
+ md5sums = 01a5dd8b6bba24d6e0af076e7a8aa981
+ md5sums = SKIP
+
+pkgname = texbuild-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48c5c76e675d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: André <andre-arch@delorus.de>
+pkgname=texbuild-git
+_gitname=texbuild
+pkgver=r8.e9e6369
+pkgrel=1
+pkgdesc="This small script continuously builds a latex file in the background. It only overwrites the target pdf file upon a successful and complete build allowing to continuously watch the PDF in PDF viewer."
+arch=(any)
+url="https://github.com/pbiggar/texbuild"
+license=('GPL')
+makedepends=('git')
+source=('support-synctex.patch' 'git+https://github.com/pbiggar/texbuild.git')
+md5sums=('01a5dd8b6bba24d6e0af076e7a8aa981' 'SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -Dm755 texbuild ${pkgdir}/usr/bin/texbuild
+}
diff --git a/support-synctex.patch b/support-synctex.patch
new file mode 100644
index 000000000000..b60ef691b40b
--- /dev/null
+++ b/support-synctex.patch
@@ -0,0 +1,27 @@
+diff --git a/texbuild b/texbuild
+index 5e175f1..c95a7ea 100755
+--- a/texbuild
++++ b/texbuild
+@@ -48,12 +48,13 @@ def msg (message):
+ filename = sys.argv[1]
+ base = os.path.splitext (os.path.basename (filename))[0]
+ final = base + ".pdf"
++synctex = base + ".synctex.gz"
+ logfile = base + ".log"
+ auxfile = base + ".aux"
+
+ texbuildlogfile = "texbuild.log"
+
+-latex = ["pdflatex", "-recorder", "-interaction=nonstopmode", filename]
++latex = ["pdflatex", "-recorder", "-src-specials", "-synctex=1", "-interaction=nonstopmode", "-shell-escape", "-enable-write18", filename]
+ bibtex = ["bibtex", base]
+
+
+@@ -167,5 +168,6 @@ while (True):
+ debug ("copying log")
+ shutil.copy (logfile, "t.log")
+ shutil.copy (auxfile, "t.aux") # for bibtex
++ shutil.copy (synctex, "t.synctex.gz") # for synctex
+
+
+--