summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:51:36 +0200
committerStefan Husmann2015-06-09 00:51:36 +0200
commitb3c80617981d8925503de97c0cffa111575f30b0 (patch)
treedfee0c5679b05dc6c6c5e8aa241b6bae157f8e0b
downloadaur-b3c80617981d8925503de97c0cffa111575f30b0.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef4798e046aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = teximpatient
+ pkgdesc = TeX for the Impatient is a ~350 page book on TeX, plain TeX, and Eplain, written by Paul Abrahams, Kathryn Hargreaves, and Karl Berry.
+ pkgver = 2.3
+ pkgrel = 2
+ url = http://savannah.gnu.org/projects/teximpatient/
+ arch = any
+ license = FDL1.3
+ makedepends = texlive-core
+ makedepends = icon
+ source = http://mirror.netcologne.de/gnu/teximpatient/teximpatient-2.3.tar.gz
+ md5sums = f4f6cdc433ba16bccd8bc0c5fe5d4869
+
+pkgname = teximpatient
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de8b81291054
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=teximpatient
+pkgver=2.3
+pkgrel=2
+pkgdesc="TeX for the Impatient is a ~350 page book on TeX, plain TeX, and Eplain, written by Paul Abrahams, Kathryn Hargreaves, and Karl Berry. "
+url="http://savannah.gnu.org/projects/teximpatient/"
+arch=('any')
+license=('FDL1.3')
+makedepends=('texlive-core' 'icon')
+source=("http://mirror.netcologne.de/gnu/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('f4f6cdc433ba16bccd8bc0c5fe5d4869')
+
+build() {
+ cd $srcdir/
+ touch install.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $srcdir/
+ make DESTDIR=$pkgdir install
+}