summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-12-02 02:40:13 +0100
committerhaawda2018-12-02 02:40:13 +0100
commitc6039512fc43f05ca18e5588db6a0fe2d3e27f3b (patch)
treef0a39ad55ed831bb0cd79a83b4629c884ad60e0e
downloadaur-c6039512fc43f05ca18e5588db6a0fe2d3e27f3b.tar.gz
initial upload of git version
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD42
-rw-r--r--texinfo-install.hook11
-rw-r--r--texinfo-remove.hook10
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f5e9669e7be
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = texinfo-git
+ pkgdesc = GNU documentation system for on-line information and printed output
+ pkgver = r8408.7ed10a17c
+ pkgrel = 1
+ url = http://www.gnu.org/software/texinfo/
+ arch = i686
+ arch = x86_64
+ groups = base
+ groups = base-devel
+ license = GPL
+ makedepends = git
+ makedepends = help2man
+ depends = coreutils
+ provides = texinfo
+ conflicts = texinfo
+ options = !makeflags
+ options = libtool
+ source = texinfo-git::git://git.savannah.gnu.org/texinfo.git
+ source = texinfo-install.hook
+ source = texinfo-remove.hook
+ sha256sums = SKIP
+ sha256sums = 66ab7eab5ecdd7757081a743f94e6f4d2e783b61db5024344450748bf1bf8eb9
+ sha256sums = 7300f03ac56e32564fb508b0dd07839d2428a422dcf13fd3246863f7ccb1965e
+
+pkgname = texinfo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56a642ed774f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=texinfo-git
+pkgver=r8408.7ed10a17c
+pkgrel=1
+pkgdesc="GNU documentation system for on-line information and printed output"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org/software/texinfo/"
+license=('GPL')
+groups=('base' 'base-devel')
+depends=('coreutils')
+makedepends=('git' 'help2man')
+provides=('texinfo')
+conflicts=('texinfo')
+source=("$pkgname::git://git.savannah.gnu.org/texinfo.git"
+ texinfo-install.hook
+ texinfo-remove.hook)
+sha256sums=('SKIP'
+ '66ab7eab5ecdd7757081a743f94e6f4d2e783b61db5024344450748bf1bf8eb9'
+ '7300f03ac56e32564fb508b0dd07839d2428a422dcf13fd3246863f7ccb1965e')
+options=('!makeflags' 'libtool')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" $(git rev-list --count HEAD) $(git describe --always)
+}
+
+build() {
+ export LANG=C
+ cd $pkgname
+ ./autogen.sh
+ ./configure --prefix=/usr --libexecdir=/usr/lib
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir/" install
+ install -dm755 "$pkgdir"/usr/share/libalpm/hooks/
+ cd "$srcdir"
+ install -m644 texinfo-{install,remove}.hook \
+ "$pkgdir"/usr/share/libalpm/hooks/
+}
diff --git a/texinfo-install.hook b/texinfo-install.hook
new file mode 100644
index 000000000000..80f7896298de
--- /dev/null
+++ b/texinfo-install.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Type = File
+Operation = Install
+Operation = Upgrade
+Target = usr/share/info/*
+
+[Action]
+Description = Updating the info directory file...
+When = PostTransaction
+Exec = /bin/sh -c 'while read -r f; do install-info "$f" /usr/share/info/dir 2> /dev/null; done'
+NeedsTargets
diff --git a/texinfo-remove.hook b/texinfo-remove.hook
new file mode 100644
index 000000000000..e57e66637c0b
--- /dev/null
+++ b/texinfo-remove.hook
@@ -0,0 +1,10 @@
+[Trigger]
+Type = File
+Operation = Remove
+Target = usr/share/info/*
+
+[Action]
+Description = Removing old entries from the info directory file...
+When = PreTransaction
+Exec = /bin/sh -c 'while read -r f; do install-info --delete "$f" /usr/share/info/dir 2> /dev/null; done'
+NeedsTargets