summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosiah Schwab2016-01-20 11:07:40 -0800
committerJosiah Schwab2016-01-20 11:07:40 -0800
commitfd35829566dfac67970d4390898132ba8f83941f (patch)
tree19be5bd250a098d1a545841b72594c9af509d063
downloadaur-fd35829566dfac67970d4390898132ba8f83941f.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--texlive-aastex6.install16
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1f4d85092e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = texlive-aastex6
+ pkgdesc = Package for preparing papers in American Astronomical Society (AAS) journals
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://journals.aas.org/authors/aastex.html
+ install = texlive-aastex6.install
+ arch = i686
+ arch = x86_64
+ depends = texlive-core
+ provides = texlive-aastex6
+ source = http://journals.aas.org/authors/aastex/aastex6.cls
+ source = http://journals.aas.org/authors/aastex/aasjournal.bst
+ sha1sums = efa9981ebbec6396249f82fee3b0a519dd59131a
+ sha1sums = 1f07745f3576b78268cea940effe9898c148abe3
+
+pkgname = texlive-aastex6
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c640ed1a2844
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Original author: Josiah Schwab <jschwab at gmail dot com>
+# Maintainer: Josiah Schwab <jschwab at gmail dot com>
+
+pkgname=texlive-aastex6
+pkgdesc="Package for preparing papers in American Astronomical Society (AAS) journals "
+pkgver=1.0
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://journals.aas.org/authors/aastex.html"
+depends=('texlive-core')
+provides=('texlive-aastex6')
+install=texlive-aastex6.install
+source=('http://journals.aas.org/authors/aastex/aastex6.cls'
+ 'http://journals.aas.org/authors/aastex/aasjournal.bst')
+sha1sums=('efa9981ebbec6396249f82fee3b0a519dd59131a'
+ '1f07745f3576b78268cea940effe9898c148abe3')
+
+package() {
+ cd "$srcdir"
+
+ # install current files (v3)
+ install -Dm644 aastex6.cls $pkgdir/usr/share/texmf-dist/tex/latex/aastex6/aastex6.cls
+ install -Dm644 aasjournal.bst $pkgdir/usr/share/texmf-dist/bibtex/bst/aastex6/aasjournal.bst
+
+
+}
diff --git a/texlive-aastex6.install b/texlive-aastex6.install
new file mode 100644
index 000000000000..d74fd61a62e4
--- /dev/null
+++ b/texlive-aastex6.install
@@ -0,0 +1,16 @@
+post_install() {
+ post_remove
+ echo "The aasjournal.bst file was installed in:"
+ kpsewhich aasjournal.bst
+ echo "The aastex6.cls file was installed in:"
+ kpsewhich aastex6.cls
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}