summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXyne2015-06-21 02:46:14 +0000
committerXyne2015-06-21 02:46:14 +0000
commit552159484896b76235a3fd322956136736820ed4 (patch)
tree34c2c813b87ecc8b58322a1db5c5c38b79aa2a6b
downloadaur-552159484896b76235a3fd322956136736820ed4.tar.gz
Initial import.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--texlive-achemso.install14
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c63d0d6423a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlive-achemso
+ pkgdesc = LaTeX support for American Chemical Society journal submissions.
+ pkgver = 3.9a
+ pkgrel = 1
+ url = http://ctan.org/tex-archive/macros/latex/contrib/achemso
+ install = texlive-achemso.install
+ arch = any
+ license = custom
+ depends = texlive-bin
+ source = http://mirrors.ctan.org/macros/latex/contrib/achemso.zip
+ sha1sums = 1e2ad3aef42a5ec3b9806cf0dbf324cba470ce00
+
+pkgname = texlive-achemso
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..801e13c7c8e1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Xyne <ac xunilhcra enyx, backwards>
+
+_basename=achemso
+pkgname=texlive-"$_basename"
+pkgver=3.9a
+pkgrel=1
+pkgdesc="LaTeX support for American Chemical Society journal submissions."
+arch=('any')
+depends=('texlive-bin')
+# url="http://ctan.org/pkg/$_basename"
+url="http://ctan.org/tex-archive/macros/latex/contrib/$_basename"
+license=('custom')
+# source=("http://mirrors.ctan.org/macros/latex/contrib/$_basename/$_basename.dtx")
+source=("http://mirrors.ctan.org/macros/latex/contrib/$_basename.zip")
+install=$pkgname.install
+
+package() {
+ mkdir -p -- "$pkgdir"/usr/share/texmf/
+ cd -- "$pkgdir"/usr/share/texmf/
+ bsdtar -xf "$srcdir/$_basename".zip
+ find "$pkgdir" -type f -exec chmod 644 {} \+
+ find "$pkgdir" -type d -exec chmod 755 {} \+
+}
+
+sha1sums=('1e2ad3aef42a5ec3b9806cf0dbf324cba470ce00')
diff --git a/texlive-achemso.install b/texlive-achemso.install
new file mode 100644
index 000000000000..9ad68f217d03
--- /dev/null
+++ b/texlive-achemso.install
@@ -0,0 +1,14 @@
+# from the texlive-bin package
+post_install() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+# echo -n "creating all formats..."
+# usr/bin/fmtutil-sys --all 1>/dev/null
+# echo " done."
+# echo " (logs are under /var/lib/texmf/web2c/<engine>/<formatname>.log)"
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+