summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Fabijan2015-06-13 09:22:24 +0200
committerDavid Fabijan2015-06-13 09:22:24 +0200
commitdbb758da0e1761072fa34c22f67b0ca04165167d (patch)
tree37f4512589e4f9ad53223f37a98dffa8cdc4a131
downloadaur-dbb758da0e1761072fa34c22f67b0ca04165167d.tar.gz
Initail upload to AUR4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD36
-rw-r--r--texlive-acrotex.install13
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56dc752c78c5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlive-acrotex
+ pkgdesc = A LaTeX bundle for webpages, pdf forms and includin JavaSript into LaTeX
+ pkgver = 6.7p
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/macros/latex/contrib/acrotex
+ install = texlive-acrotex.install
+ arch = any
+ license = GPL
+ depends = texlive-core
+ source = http://mirrors.ctan.org/macros/latex/contrib/acrotex.zip
+ md5sums = b4973e088d36d403b14f26327680aa24
+
+pkgname = texlive-acrotex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9c62428fcb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: McLenin <mclenin at gooogles email>
+pkgname=texlive-acrotex
+pkgver=6.7p
+pkgrel=1
+license=('GPL')
+depends=('texlive-core')
+pkgdesc="A LaTeX bundle for webpages, pdf forms and includin JavaSript into LaTeX"
+url="http://www.ctan.org/tex-archive/macros/latex/contrib/acrotex"
+arch=('any')
+install=texlive-acrotex.install
+source=(http://mirrors.ctan.org/macros/latex/contrib/acrotex.zip)
+md5sums=('b4973e088d36d403b14f26327680aa24')
+
+build()
+{
+ cd $srcdir/acrotex
+ latex acrotex.ins
+ latex dljslib.ins
+ latex eforms.ins
+ latex exerquiz.ins
+ latex insdljs.ins
+ latex taborder.ins
+ latex web.ins
+}
+
+package()
+{
+ cd $srcdir/acrotex
+
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/acrotex
+ cp {*.sty,*.def,*.cfg,*.js} $pkgdir/usr/share/texmf/tex/latex/acrotex
+
+ mkdir -p $pkgdir/usr/share/doc/texlive-acrotex
+ cd $srcdir/acrotex/doc
+ cp * $pkgdir/usr/share/doc/texlive-acrotex
+}
diff --git a/texlive-acrotex.install b/texlive-acrotex.install
new file mode 100644
index 000000000000..1b335f411729
--- /dev/null
+++ b/texlive-acrotex.install
@@ -0,0 +1,13 @@
+post_install() {
+ post_remove
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}
+