summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-11 16:20:32 +0200
committerMattias Andrée2015-06-11 16:20:32 +0200
commit87d91c40ea27220bb30877f6e57ba3a3b27ff212 (patch)
tree53880e821a43c1611b3a26a660bb7b11d2c8d4d2
downloadaur-87d91c40ea27220bb30877f6e57ba3a3b27ff212.tar.gz
Initial import, version 0:1.0.1-2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--texlive-flashcards.install14
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88f058fb28dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlive-flashcards
+ pkgdesc = A class for typesetting flashcards.
+ pkgver = 1.0.1
+ pkgrel = 2
+ url = http://ctan.org/pkg/flashcards
+ install = texlive-flashcards.install
+ arch = any
+ license = GPL
+ depends = texlive-core
+ source = http://mirror.ctan.org/macros/latex/contrib/flashcards.zip
+ md5sums = 21f85c9b291a0d06e815ce09d89f4463
+
+pkgname = texlive-flashcards
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf610be5d1cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Contributor: tze <tze@datalove.me>
+
+pkgname=texlive-flashcards
+pkgver=1.0.1
+pkgrel=2
+license=('GPL')
+depends=('texlive-core')
+pkgdesc="A class for typesetting flashcards."
+url="http://ctan.org/pkg/flashcards"
+arch=('any')
+install=texlive-flashcards.install
+source=(http://mirror.ctan.org/macros/latex/contrib/flashcards.zip)
+md5sums=('21f85c9b291a0d06e815ce09d89f4463')
+
+build ()
+{
+ cd "${srcdir}/flashcards"
+ latex flashcards.ins
+}
+
+package ()
+{
+ cd "${srcdir}/flashcards"
+ mkdir -p -- "${pkgdir}/usr/share/texmf/tex/latex/flashcards"
+
+ cp -- flashcards.cls "${pkgdir}/usr/share/texmf/tex/latex/flashcards"
+ cp -- *.cfg "${pkgdir}/usr/share/texmf/tex/latex/flashcards"
+
+ install -D -- "${srcdir}/flashcards/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
diff --git a/texlive-flashcards.install b/texlive-flashcards.install
new file mode 100644
index 000000000000..996ec2364eb4
--- /dev/null
+++ b/texlive-flashcards.install
@@ -0,0 +1,14 @@
+post_install() {
+ post_remove
+ echo "The file was installed in:"
+ kpsewhich flashcards.cls
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}