summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-01-29 13:51:50 +0800
committerSukanka2022-01-29 13:51:50 +0800
commit792deeca2cfe9320770e89679c00299f596ec79b (patch)
treed8b97804644fbac987037d0ae2b0e4bc0a8d797b
parent7a4a4e341ae74afbd101e2b3ba07049782e1cbb4 (diff)
downloadaur-792deeca2cfe9320770e89679c00299f596ec79b.tar.gz
replace http with https
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b73bcd0cf45b..2d2ac06338da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -46,7 +46,7 @@ pkgbase = texlive-full
conflicts = texlive-langjapanese
conflicts = texlive-langkorean
options = !strip
- source = http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
+ source = https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
sha256sums = SKIP
pkgname = texlive-full
diff --git a/PKGBUILD b/PKGBUILD
index ae4628260fc7..c870994ad048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,9 @@ url="http://www.tug.org/texlive/"
arch=("x86_64")
license=("GPL")
makedepends=('rsync')
-provides=('texlive-bin' $(pacman -Sgq texlive-most texlive-lang))
-conflicts=('texlive-bin' 'git-latexdiff' $(pacman -Sgq texlive-most texlive-lang))
-source=("http://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz")
+provides=('texlive-bin' 'texlive-bibtexextra' 'texlive-core' 'texlive-fontsextra' 'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra' 'texlive-music' 'texlive-pictures' 'texlive-pstricks' 'texlive-publishers' 'texlive-science' 'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra' 'texlive-langgreek' 'texlive-langjapanese' 'texlive-langkorean')
+conflicts=('texlive-bin' 'git-latexdiff' 'texlive-bibtexextra' 'texlive-core' 'texlive-fontsextra' 'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra' 'texlive-music' 'texlive-pictures' 'texlive-pstricks' 'texlive-publishers' 'texlive-science' 'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra' 'texlive-langgreek' 'texlive-langjapanese' 'texlive-langkorean')
+source=("https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz")
sha256sums=('SKIP')
#PKGEXT='.pkg.tar'
options=(!strip)
@@ -19,7 +19,7 @@ options=(!strip)
# You can choose a mirror and rsync directory here.
# _syncdir works as a local CTAN mirror (about 4.5GiB) for faster installation
-_mirror='mirrors.bfsu.edu.cn/CTAN/systems/texlive/tlnet/'
+_mirror='rsync.dante.ctan.org/CTAN'
_syncdir="CTAN/tlnet"
pkgver(){
@@ -40,7 +40,8 @@ prepare(){
# syncing repository
mkdir -p ${_syncdir}
- rsync -a --delete rsync://${_mirror} ${_syncdir}
+ msg2 "Syncing local mirror"
+ rsync -av --delete --info=progress2 --info=name0 rsync://${_mirror} ${_syncdir}
}
@@ -91,5 +92,9 @@ package() {
# remove profile file and installation log, and wrong man link.
rm -rf ${pkgdir}/usr/bin/man
rm -vf "${pkgdir}/opt/texlive/${_year}/tlpkg/texlive.profile"
+
+ msg2 "Removing files for Windows"
+ rm -rf ${pkgdir}/opt/texlive/${_year}/texmf-dist/scripts/context/stubs/{win64,mswin}/*
+ find -H ${pkgdir} -name "*.bat" -print0 | xargs -0 rm -rf
}
# vim:set ts=2 sw=2 et: