summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2023-03-21 22:47:45 +0800
committersukanka2023-03-21 22:47:45 +0800
commite9088dbf36ca3d5c7216418a56f7272454858a22 (patch)
treefd4898f991d201cf5aec87354c70ef5fa34e7085
parent677c306ceb1bad6445759484aeddaacbb5ee7d34 (diff)
downloadaur-e9088dbf36ca3d5c7216418a56f7272454858a22.tar.gz
update to 2023, clean depends and provides/conflicts
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD41
2 files changed, 36 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0341eb5be014..84d09bb641e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = texlive-full
pkgdesc = This packages provides texlive-full in /opt. It also tricks ArchLinux into thinking it has its texlive packages installed.
- pkgver = 2022.20221031
+ pkgver = 2023.20230321
pkgrel = 1
epoch = 1
url = http://www.tug.org/texlive/
@@ -8,10 +8,10 @@ pkgbase = texlive-full
license = custom
makedepends = rsync
depends = libxcrypt-compat
- provides = asymptote
+ depends = asymptote
+ depends = psutils
+ depends = t1utils
provides = git-latexdiff
- provides = psutils
- provides = t1utils
provides = texlive-bin
provides = texlive-bibtexextra
provides = texlive-core
@@ -32,11 +32,7 @@ pkgbase = texlive-full
provides = texlive-langjapanese
provides = texlive-langkorean
provides = texlive-htmlxml
- conflicts = asymptote
conflicts = git-latexdiff
- conflicts = haskell-citeproc
- conflicts = psutils
- conflicts = t1utils
conflicts = texlive-bin
conflicts = texlive-bibtexextra
conflicts = texlive-core
@@ -58,7 +54,7 @@ pkgbase = texlive-full
conflicts = texlive-langkorean
conflicts = texlive-htmlxml
options = !strip
- source = install-tl-unx-2022.20221031.tar.gz::https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
+ source = install-tl-unx-2023.20230321.tar.gz::https://mirror.ctan.org/systems/texlive/tlnet/install-tl-unx.tar.gz
source = LICENSE.TL::https://tug.org/texlive/LICENSE.TL
sha256sums = SKIP
sha256sums = e8f070b2d1a9bad00af9d6cb94e687f2120591d092c8dab8727249b70adc96d0
diff --git a/PKGBUILD b/PKGBUILD
index e27584bdf492..ecd176a362db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Butui Hu <hot123tea123@gmail.com>
pkgname=texlive-full
-pkgver=2022.20221031
+pkgver=2023.20230321
pkgrel=1
epoch=1
pkgdesc="This packages provides texlive-full in /opt. It also tricks ArchLinux into thinking it has its texlive packages installed."
@@ -10,18 +10,16 @@ url="http://www.tug.org/texlive/"
arch=("x86_64")
license=('custom')
makedepends=('rsync')
-depends=('libxcrypt-compat')
-provides=('asymptote' 'git-latexdiff' 'psutils' 't1utils'
+depends=('libxcrypt-compat' 'asymptote' 'psutils' 't1utils')
+provides=('git-latexdiff'
'texlive-bin'
'texlive-bibtexextra' 'texlive-core' 'texlive-fontsextra'
'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra'
'texlive-music' 'texlive-pictures' 'texlive-pstricks' 'texlive-publishers'
'texlive-science'
-#
-# 'haskell-citeproc' is not provided, only citeproc-lua is provided.
'texlive-langchinese' 'texlive-langcyrillic' 'texlive-langextra'
'texlive-langgreek' 'texlive-langjapanese' 'texlive-langkorean' 'texlive-htmlxml')
-conflicts=('asymptote' 'git-latexdiff' 'haskell-citeproc' 'psutils' 't1utils'
+conflicts=('git-latexdiff'
'texlive-bin'
'texlive-bibtexextra' 'texlive-core' 'texlive-fontsextra'
'texlive-formatsextra' 'texlive-games' 'texlive-humanities' 'texlive-latexextra'
@@ -71,6 +69,26 @@ prepare(){
}
+_postfix(){
+ # remove files provided by other packages
+ # we do not link the executables from the depends to /opt/texlive/bin
+ # as it's too complicated.
+
+ cd ${pkgdir}
+ # asymptote
+ rm -rf usr/bin/{asy,xasy}
+ rm -rf usr/share/info/asy-faq.info
+ rm -rf usr/share/man/man1/{asy,xasy}.1
+
+ # psutils
+ rm -rf usr/bin/{epsffit,extractres,includeres,psbook,psjoin,psnup,psresize,psselect,pstops}
+ rm -rf usr/share/man/man1/{epsffit,extractres,includeres,psbook,psjoin,psnup,psresize,psselect,pstops,psutils}.1
+
+ # t1utils
+ rm -rf usr/bin/{t1ascii,t1asm,t1binary,t1disasm,t1mac,t1unmac}
+ rm -rf usr/share/man/man1/{t1ascii,t1asm,t1binary,t1disasm,t1mac,t1unmac}.1
+}
+
package() {
local _tldate=$(ls | grep -E '[0-9]+' -o | sort -r | head -1)
local _year=$(cat ${srcdir}/install-tl-${_tldate}/release-texlive.txt| grep -E '[0-9]+' -o)
@@ -90,12 +108,13 @@ package() {
msg2 "Linking manpage"
mkdir -p ${pkgdir}/usr/share/man/{man1,man5}
- for mann in {man1,man5}
+ for mann in {1,5}
do
- cd ${pkgdir}/opt/texlive/${_year}/texmf-dist/doc/man/$mann
- find . -type f,l -print0 |sed "s|\./||g"| while read -d $'\0' man
+ cd ${pkgdir}/opt/texlive/${_year}/texmf-dist/doc/man/man${mann}
+ # only link .1 and .5 files, not pdf
+ find . -type f,l -name "*.${mann}" -print0 |sed "s|\./||g"| while read -d $'\0' man
do
- ln -s "/opt/texlive/${_year}/texmf-dist/doc/man/$mann/${man}" "${pkgdir}/usr/share/man/$mann/"
+ ln -s "/opt/texlive/${_year}/texmf-dist/doc/man/man${mann}/${man}" "${pkgdir}/usr/share/man/man${mann}/"
done
done
@@ -125,5 +144,7 @@ package() {
msg2 "Install license file"
install -Dm644 "$srcdir"/LICENSE.TL "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE.TL
+
+ _postfix
}
# vim:set ts=2 sw=2 et: