summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-01-17 20:51:36 +0100
committerStefan Husmann2016-01-17 20:51:36 +0100
commit9bcb22f8d32c94a8caad64b2c17d03da3919b4f1 (patch)
tree5eea86572d1b8a5c0601ef171a1c850231156327
downloadaur-9bcb22f8d32c94a8caad64b2c17d03da3919b4f1.tar.gz
initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--garamondx.maps1
-rw-r--r--texlive-garamondx.install52
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1017841480b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 19:51:04 UTC 2016
+pkgbase = texlive-garamondx
+ pkgdesc = URW Garamond No8 Adobe Type1 fonts from CTAN (for texlive)
+ pkgver = 1.099
+ pkgrel = 1
+ url = http://mirrors.ctan.org/install/fonts/garamondx.tds.zip
+ install = texlive-garamondx.install
+ arch = any
+ license = CUSTOM:alladin
+ depends = texlive-core
+ noextract = garamondx.tds.zip
+ source = http://mirrors.ctan.org/install/fonts/garamondx.tds.zip
+ source = garamondx.maps
+ md5sums = 1ced5a2bc4512dc5fc298ae21d717d63
+ md5sums = 80761a71120a9861400927b591ac463f
+
+pkgname = texlive-garamondx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70cf66011b1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=texlive-garamondx
+pkgver=1.099
+pkgrel=1
+pkgdesc="URW Garamond No8 Adobe Type1 fonts from CTAN (for texlive)"
+arch=('any')
+license=('CUSTOM:alladin')
+url=("http://mirrors.ctan.org/install/fonts/garamondx.tds.zip")
+depends=(texlive-core)
+install=$pkgname.install
+source=(http://mirrors.ctan.org/install/fonts/garamondx.tds.zip garamondx.maps)
+md5sums=('1ced5a2bc4512dc5fc298ae21d717d63'
+ '80761a71120a9861400927b591ac463f')
+noextract=garamondx.tds.zip
+
+package() {
+ _texmf_root=usr/share/texmf-dist
+ install -d "$pkgdir"/var/lib/texmf/arch/installedpkgs
+ install -m644 "$srcdir"/garamondx.maps "$pkgdir"/var/lib/texmf/arch/installedpkgs
+ install -d "$pkgdir"/$_texmf_root/
+ cd "$pkgdir"/$_texmf_root/
+ bsdtar xf "$srcdir"/garamondx.tds.zip
+ install -Dm644 "$pkgdir"/$_texmf_root/doc/fonts/garamondx/README \
+ "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rm "$pkgdir"/$_texmf_root/doc/fonts/garamondx/README
+}
+
diff --git a/garamondx.maps b/garamondx.maps
new file mode 100644
index 000000000000..d57e34a7945d
--- /dev/null
+++ b/garamondx.maps
@@ -0,0 +1 @@
+Map zgm.map
diff --git a/texlive-garamondx.install b/texlive-garamondx.install
new file mode 100644
index 000000000000..d29fe08a3599
--- /dev/null
+++ b/texlive-garamondx.install
@@ -0,0 +1,52 @@
+PKGNAME="garamondx"
+UPDMAP="etc/texmf/web2c/updmap.cfg"
+UPDMAPLOCAL="etc/texmf/web2c/updmap-local.cfg"
+SYNCWITHTREES=''
+
+MAPFILE="var/lib/texmf/arch/installedpkgs/$PKGNAME.maps"
+
+post_install() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}
+
+post_upgrade() {
+ TMPFILE=`mktemp`
+ echo ">>> texlive: saving updmap.cfg as $TMPFILE..."
+ cp "$UPDMAP" "$TMPFILE"
+ echo ">>> texlive: regenerating updmap.cfg (custom additions should go"
+ echo " into /etc/texmf/web2c/updmap-local.cfg"
+ cp usr/share/texmf-dist/web2c/updmap-hdr.cfg $UPDMAP
+ cat var/lib/texmf/arch/installedpkgs/*.maps >> $UPDMAP
+ [ -f "$UPDMAPLOCAL" ] && cat "$UPDMAPLOCAL" >> $UPDMAP
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash $SYNCWITHTREES
+ echo " done."
+}
+
+pre_remove() {
+for m in `cut -d' ' -f2 $MAPFILE`; do
+ sed -i "/\s$m/d" $UPDMAP ;
+done
+}
+
+post_remove() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+ echo ">>> texlive: updating the fontmap files with updmap..."
+ usr/bin/updmap-sys --quiet --nohash
+ echo " done."
+}