summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEsteban null2015-10-22 15:31:38 +0200
committerEsteban null2015-10-22 15:31:38 +0200
commit23b82cbf6fab90fd02fc2821376946fb3388ec0c (patch)
treebd62b343617ace9230668963dbc394146175f547
downloadaur-23b82cbf6fab90fd02fc2821376946fb3388ec0c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
-rw-r--r--texlive-ieeetran.install9
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45a9f798b10f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlive-ieeetran
+ pkgdesc = LaTeX class for authors of the Institute of Electrical and Electronics Engineers (IEEE) transactions journals and conferences.
+ pkgver = 1.8b
+ pkgrel = 1
+ url = http://www.ctan.org/tex-archive/macros/latex/contrib/IEEEtran/
+ install = texlive-ieeetran.install
+ arch = any
+ license = LPPL
+ depends = texlive-bin
+ source = http://mirrors.ctan.org/macros/latex/contrib/IEEEtran.zip
+ sha1sums = 85928c0c8d286ff3dbed07c29ca6fb7d124e7c3e
+
+pkgname = texlive-ieeetran
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30233072df72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: estebon <sanestebon at gmail dot com>
+_basename=IEEEtran
+pkgname=texlive-ieeetran
+# Use "grep ProvidesExplPackage -r src/" to find the version.
+pkgver=1.8b
+pkgrel=1
+pkgdesc="LaTeX class for authors of the Institute of Electrical and Electronics Engineers (IEEE) transactions journals and conferences."
+arch=('any')
+depends=('texlive-bin')
+url="http://www.ctan.org/tex-archive/macros/latex/contrib/"$_basename"/"
+license=('LPPL')
+source=(http://mirrors.ctan.org/macros/latex/contrib/"$_basename".zip)
+install="$pkgname".install
+
+package() {
+ mkdir -p -- "$pkgdir"/usr/share/texmf-dist/tex/latex
+ cd -- "$pkgdir"/usr/share/texmf-dist/tex/latex
+ bsdtar -xf "$srcdir/$_basename".zip
+ find "$pkgdir" -type f -exec chmod 644 {} \+
+ find "$pkgdir" -type d -exec chmod 755 {} \+
+}
+
+sha1sums=('85928c0c8d286ff3dbed07c29ca6fb7d124e7c3e')
diff --git a/texlive-ieeetran.install b/texlive-ieeetran.install
new file mode 100644
index 000000000000..6dbc60c74e30
--- /dev/null
+++ b/texlive-ieeetran.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ">>> texlive: updating the filename database..."
+ usr/bin/mktexlsr
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+