summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2022-04-30 13:01:00 +0200
committerXZS2022-09-13 14:08:14 +0200
commit35b5a84f4257d29cd03a25f1c8b91ac9a6e9ff2b (patch)
treec0bba316f2c7eecb8bbb27d8926cc24be7d2c1df
parent98b2e63890b87d96078026911cfff4ad2b51d70c (diff)
downloadaur-texlive-localmanager-git.tar.gz
move to 2022 release; add minor fix
Fixes a small problem with creating PKGBUILDs for CTAN packages which are not in any texlive collection; we avoid adding the 'conflict' for such cases.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
-rw-r--r--tllocalmgr-2022.patch (renamed from tllocalmgr-2021.patch)6
-rw-r--r--tllocalmgr-better-conflicts.patch21
4 files changed, 44 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a8a6fc62534..9bd9c250495a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = texlive-localmanager-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
pkgver = r84.bbd8488
- pkgrel = 4
+ pkgrel = 5
url = https://gitlab.archlinux.org/remy/texlive-localmanager.git
arch = any
license = GPL
makedepends = git
depends = texlive-core>=2016
- depends = texlive-core<2022
+ depends = texlive-core<2023
depends = perl-libwww
depends = perl-term-shellui
depends = perl-term-readline-gnu
@@ -16,16 +16,18 @@ pkgbase = texlive-localmanager-git
provides = texlive-localmanager=r84.bbd8488
conflicts = texlive-localmanager
source = texlive-localmanager::git+https://gitlab.archlinux.org/remy/texlive-localmanager.git
- source = tllocalmgr-2021.patch
+ source = tllocalmgr-2022.patch
source = tllocalmgr-enhance.patch
source = tllocalmgr-fix-texlive-local-match.patch
source = tllocalmgr-pkgs-nicer-error.patch
source = tllocalmgr-mirror-opt.patch
+ source = tllocalmgr-better-conflicts.patch
sha256sums = SKIP
- sha256sums = cd12f1927fa9d950855aab91b30039d0cbb328a8c7899382286d3ace16bb6a3b
+ sha256sums = 7eb0982890b2d4de29d391db59dd4a8c6308bca2327433f08da265bf69ca71ca
sha256sums = 22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236
sha256sums = a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7
sha256sums = 23f103c606eb595d8c114aee2ca3006a09588370087b959419f86a4a8ce25a43
sha256sums = d7064657f6336bed7be230fc05df800e6bdcee31d10c718b4b9b1b55f7f26c8a
+ sha256sums = 380cdb0dd8531dcab13b8da70506214bccb7252ddd19ad50a5be25fac3b39ea2
pkgname = texlive-localmanager-git
diff --git a/PKGBUILD b/PKGBUILD
index 9916572d6d5e..be271e09fc3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=texlive-localmanager-git
_pkgname="${pkgname%-git}"
pkgver=r84.bbd8488
-pkgrel=4
+pkgrel=5
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
url='https://gitlab.archlinux.org/remy/texlive-localmanager.git'
@@ -15,7 +15,7 @@ license=('GPL')
provides=("texlive-localmanager=$pkgver")
conflicts=('texlive-localmanager')
depends=('texlive-core>=2016'
- 'texlive-core<2022'
+ 'texlive-core<2023'
'perl-libwww'
'perl-term-shellui'
'perl-term-readline-gnu'
@@ -24,17 +24,19 @@ depends=('texlive-core>=2016'
makedepends=('git')
source=("${_pkgname}::git+https://gitlab.archlinux.org/remy/texlive-localmanager.git"
- 'tllocalmgr-2021.patch'
+ 'tllocalmgr-2022.patch'
'tllocalmgr-enhance.patch'
'tllocalmgr-fix-texlive-local-match.patch'
'tllocalmgr-pkgs-nicer-error.patch'
- 'tllocalmgr-mirror-opt.patch')
+ 'tllocalmgr-mirror-opt.patch'
+ 'tllocalmgr-better-conflicts.patch')
sha256sums=('SKIP'
- 'cd12f1927fa9d950855aab91b30039d0cbb328a8c7899382286d3ace16bb6a3b'
+ '7eb0982890b2d4de29d391db59dd4a8c6308bca2327433f08da265bf69ca71ca'
'22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236'
'a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7'
'23f103c606eb595d8c114aee2ca3006a09588370087b959419f86a4a8ce25a43'
- 'd7064657f6336bed7be230fc05df800e6bdcee31d10c718b4b9b1b55f7f26c8a')
+ 'd7064657f6336bed7be230fc05df800e6bdcee31d10c718b4b9b1b55f7f26c8a'
+ '380cdb0dd8531dcab13b8da70506214bccb7252ddd19ad50a5be25fac3b39ea2')
pkgver() {
cd "$_pkgname"
@@ -47,8 +49,8 @@ pkgver() {
prepare() {
cd "$_pkgname"
- # update to handle texlive-2021 releases
- patch -p1 < "$srcdir/tllocalmgr-2021.patch"
+ # update to handle texlive-2022 releases
+ patch -p1 < "$srcdir/tllocalmgr-2022.patch"
# enhances the tllocalmgr script a bit
# thanks: @sharethewisdom and @cobaltspace
@@ -63,6 +65,10 @@ prepare() {
# correctly pass --mirror option
patch -p1 < "$srcdir/tllocalmgr-mirror-opt.patch"
+
+ # some CTAN packages are not in any texlive collection, so there is
+ # no need to set a conflict within PKGBUILD
+ patch -p1 < "$srcdir/tllocalmgr-better-conflicts.patch"
}
package() {
diff --git a/tllocalmgr-2021.patch b/tllocalmgr-2022.patch
index 35a52c1f982d..92af3ec1a54e 100644
--- a/tllocalmgr-2021.patch
+++ b/tllocalmgr-2022.patch
@@ -3,11 +3,11 @@ index e27f70b..b6e5101 100644
--- a/tlpkg/TeXLive/TLConfig.pm
+++ b/tlpkg/TeXLive/TLConfig.pm
@@ -57,7 +57,7 @@ BEGIN {
-
+
# the year of our release, will be used in the location of the
# network packages, and in menu names, and other places.
-$ReleaseYear = 2019;
-+$ReleaseYear = 2021;
-
++$ReleaseYear = 2022;
+
# users can upgrade from this year to the current year; might be the
# same as the release year, or any number of releases earlier.
diff --git a/tllocalmgr-better-conflicts.patch b/tllocalmgr-better-conflicts.patch
new file mode 100644
index 000000000000..293c898c319e
--- /dev/null
+++ b/tllocalmgr-better-conflicts.patch
@@ -0,0 +1,21 @@
+--- a/tllocalmgr 2022-04-30 12:51:53.267184213 +0200
++++ b/tllocalmgr 2022-04-30 12:54:50.636930181 +0200
+@@ -639,6 +639,9 @@
+ open PKGBUILD, "> $ROOT/builds/$pkg/PKGBUILD";
+ my $newver = $tlpkg->revision;
+ my $col = $collectionsbypkg{$pkg};
++ my $conflict = (defined $col and $col ne '')
++ ? "conflicts=('texlive-$col>=$YEAR.$newver')"
++ : "conflicts=()";
+ my $pkgsha512 = $tlpkg->containerchecksum;
+ #TODO download it first and compare the checksum
+ # if it differs ask the user if the PKGBUILD
+@@ -653,7 +656,7 @@
+ arch=('any')
+ groups=('texlive-local')
+ depends=('texlive-core')
+-conflicts=('texlive-$col>=$YEAR.$newver')
++$conflict
+ url='http://tug.org/texlive/'
+ source=('$TLARCHIVE/$pkg.tar.xz')
+ sha512sums=($pkgsha512)