summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-06-30 20:00:26 +0200
committerXZS2022-09-13 14:08:13 +0200
commit052aa138add8f8221a07502d57e602467c063eed (patch)
tree4146a57b48a5a05c56fa0a9d76454989b424724c
parenta6c094b43b3443a81f6f2d0dc0cccf5b2244c705 (diff)
downloadaur-052aa138add8f8221a07502d57e602467c063eed.tar.gz
update git URL to gitlab.archlinux.org
this unfortunately changes the version number, as the tags from the old git.archlinux.org repo where not migrated...
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 948c67695d14..ffc0223758fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = texlive-localmanager-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
- pkgver = v0.7.r3.gbbd8488
- pkgrel = 7
+ pkgver = r84.bbd8488
+ pkgrel = 1
url = https://git.archlinux.org/users/remy/texlive-localmanager.git/
arch = any
license = GPL
@@ -13,9 +13,11 @@ pkgbase = texlive-localmanager-git
depends = perl-term-readline-gnu
depends = perl-list-moreutils
depends = perl-lwp-protocol-https
+ provides = texlive-localmanager=r84.bbd8488
provides = texlive-localmanager=v0.7.r3.gbbd8488
+ provides = tllocalmgr-git=v0.7.r3.gbbd8488
conflicts = texlive-localmanager
- source = texlive-localmanager::git+http://git.archlinux.org/users/remy/texlive-localmanager.git
+ source = texlive-localmanager::git+https://gitlab.archlinux.org/remy/texlive-localmanager.git
source = tllocalmgr-2021.patch
source = tllocalmgr-enhance.patch
source = tllocalmgr-fix-texlive-local-match.patch
@@ -27,4 +29,3 @@ pkgbase = texlive-localmanager-git
sha256sums = 1538426adada826f8faeed826e9be5f5610ade23ce0437535e39662294e6e108
pkgname = texlive-localmanager-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 80b6e4c0ff09..956301deaca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
pkgname=texlive-localmanager-git
_pkgname="${pkgname%-git}"
-pkgver=v0.7.r3.gbbd8488
-pkgrel=7
+pkgver=r84.bbd8488
+pkgrel=1
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
url='https://git.archlinux.org/users/remy/texlive-localmanager.git/'
license=('GPL')
-provides=("texlive-localmanager=$pkgver")
+provides=("texlive-localmanager=$pkgver" "texlive-localmanager=v0.7.r3.gbbd8488" "$pkgname=v0.7.r3.gbbd8488")
conflicts=('texlive-localmanager')
depends=('texlive-core>=2016'
'texlive-core<2022'
@@ -23,7 +23,7 @@ depends=('texlive-core>=2016'
'perl-lwp-protocol-https')
makedepends=('git')
-source=("${_pkgname}::git+http://git.archlinux.org/users/remy/texlive-localmanager.git"
+source=("${_pkgname}::git+https://gitlab.archlinux.org/remy/texlive-localmanager.git"
'tllocalmgr-2021.patch'
'tllocalmgr-enhance.patch'
'tllocalmgr-fix-texlive-local-match.patch'
@@ -36,7 +36,10 @@ sha256sums=('SKIP'
pkgver() {
cd "$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {