summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-02-02 22:08:27 +0100
committerXZS2022-09-13 14:07:58 +0200
commit667feb1bfe4fe00deb025884432437f806112516 (patch)
tree71d0f8ff04c7e3c9f23b7e8ecb03bf548ecb5540
parent7d2b2eebe9122e783992f2e1d719330cab25da0b (diff)
downloadaur-667feb1bfe4fe00deb025884432437f806112516.tar.gz
initial commit
by new maintainer
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD47
-rw-r--r--tllocalmgr.patch58
3 files changed, 91 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e83255f47c36..7f921d0f9dd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = texlive-localmanager-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
- pkgver = 0.7
- pkgrel = 2
- url = http://wiki.archlinux.org/index.php?title=TeXLive#TeXLive_Local_Manager
- install = tllocalmgr.install
+ pkgver = v0.7.r3.gbbd8488
+ pkgrel = 1
+ url = https://git.archlinux.org/users/remy/texlive-localmanager.git/
arch = any
license = GPL
makedepends = git
@@ -13,11 +12,12 @@ pkgbase = texlive-localmanager-git
depends = perl-term-readline-gnu
depends = perl-list-moreutils
depends = perl-lwp-protocol-https
- provides = texlive-localmanager=0.7
+ provides = texlive-localmanager=v0.7.r3.gbbd8488
conflicts = texlive-localmanager
- source = texlive-localmanager::git://projects.archlinux.org/users/remy/texlive-localmanager.git
- md5sums = SKIP
+ source = texlive-localmanager::git://git.archlinux.org/users/remy/texlive-localmanager.git
+ source = tllocalmgr.patch
sha256sums = SKIP
+ sha256sums = 22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236
pkgname = texlive-localmanager-git
diff --git a/PKGBUILD b/PKGBUILD
index 5523456eaf3f..246ec845762e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,47 @@
-# Maintainer: XZS <d dot f dot fischer at web dot de>
+# Maintainer: Hans-Nikolai Viessmann <hans at viess dot mn>
+# Contributor: XZS <d dot f dot fischer at web dot de>
# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Rémy Oudompheng <remy@archlinux.org>
# Contributor: Firmicus <francois . archlinux . org>
pkgname=texlive-localmanager-git
-pkgver=0.7
-pkgrel=2
-pkgdesc="A shell and command-line utility to manage TeXLive on Arch Linux"
+_pkgname="${pkgname%-git}"
+pkgver=v0.7.r3.gbbd8488
+pkgrel=1
+pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
-url="http://wiki.archlinux.org/index.php?title=TeXLive#TeXLive_Local_Manager"
+url='https://git.archlinux.org/users/remy/texlive-localmanager.git/'
license=('GPL')
+provides=("texlive-localmanager=$pkgver")
+conflicts=('texlive-localmanager')
depends=('texlive-core>=2011'
'perl-libwww'
'perl-term-shellui'
'perl-term-readline-gnu'
'perl-list-moreutils'
'perl-lwp-protocol-https')
-install='tllocalmgr.install'
+makedepends=('git')
+
+source=("${_pkgname}::git://git.archlinux.org/users/remy/texlive-localmanager.git"
+ 'tllocalmgr.patch')
+sha256sums=('SKIP'
+ '22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236')
-_giturl="git://projects.archlinux.org/users/remy/${pkgname%-git}.git"
-makedepends+=('git')
-source+=("${_gitname:=${pkgname%-git}}::${_giturl:-git+$url}")
-for integ in $(get_integlist)
-do
- typeset -n array="${integ}sums"
- array+=('SKIP')
-done
-provides+=("$_gitname=$pkgver")
-conflicts+=("$_gitname")
pkgver() {
- cd ${_gitname:-$pkgname}
- git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
- [ ${PIPESTATUS[0]} -eq 0 ] || \
-printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_pkgname
+
+ # enhances the tllocalmgr script a bit
+ # thanks: @sharethewisdom and @cobaltspace
+ patch -p1 < "$srcdir/tllocalmgr.patch"
}
package() {
- cd "$_gitname"
+ cd $_pkgname
install -d $pkgdir/usr/{bin,share/texmf/arch/tlpkg/TeXLive}
install -m755 tllocalmgr $pkgdir/usr/bin/
cd tlpkg/TeXLive
diff --git a/tllocalmgr.patch b/tllocalmgr.patch
new file mode 100644
index 000000000000..a949ea909313
--- /dev/null
+++ b/tllocalmgr.patch
@@ -0,0 +1,58 @@
+diff --git a/tllocalmgr b/tllocalmgr
+index b947ed2..e238263 100755
+--- a/tllocalmgr
++++ b/tllocalmgr
+@@ -227,6 +227,7 @@ my @updatedpkgs; # pkgs for which updates are available
+ foreach my $col (sort keys %installedcol_versions) {
+ #my $installedver = `pacman -Q texlive-$col`;
+ #$installedver =~ s/texlive-$col $YEAR\.([0-9]+)-.+/$1/;
++ next if ( $col eq "tlpdb" ) ;
+ next unless ( $installedcol_versions{$col} < $versions{$col} ) ;
+ foreach my $pkg (sort @{$tlpackages{$col}}) {
+ my $tlpkg = $tlpdb->get_package($pkg);
+@@ -636,6 +637,7 @@ pkgrel=1
+ pkgdesc="TeX Live - local installation of CTAN package $pkg"
+ license=('GPL')
+ arch=('any')
++groups=('texlive-local')
+ depends=('texlive-core')
+ conflicts=('texlive-$col>=$YEAR.$newver')
+ url='http://tug.org/texlive/'
+@@ -670,11 +672,12 @@ EOF
+ # open INSTALL, "> $ROOT/builds/$pkg/texlive.install";
+ # print INSTALL $TLINSTALL;
+ # close INSTALL;
+- print LOG "* Running makepkg -ci on $ROOT/builds/$pkg/PKGBUILD\n";
++ system( "makepkg --printsrcinfo > .SRCINFO" );
++ print LOG "* Running makepkg -i on $ROOT/builds/$pkg/PKGBUILD\n";
+ chdir "$ROOT/builds/$pkg";
+ system( "test -f $pkg.tar.xz && rm $pkg.tar.xz" );
+ # TODO : catch error if makepkg fails
+- system( "makepkg -ci" );
++ system( "makepkg -i" );
+ }
+
+ print "\n>>> Finished. Don't forget to run 'texhash' to update your file database.\n";
+@@ -729,6 +732,7 @@ pkgrel=1
+ pkgdesc="TeX Live - local installation of CTAN package $pkg (documentation and sources)"
+ license=('GPL')
+ arch=('any')
++groups=('texlive-local')
+ depends=('texlive-core')
+ url='http://tug.org/texlive/'
+ EOF
+@@ -773,11 +777,12 @@ EOF
+ # open INSTALL, "> $ROOT/builds/$pkg/texlive.install";
+ # print INSTALL $TLINSTALL;
+ # close INSTALL;
+- print LOG "* Running makepkg -ci on $ROOT/builds/$pkg-doc/PKGBUILD\n";
++ system( "makepkg --printsrcinfo > .SRCINFO" );
++ print LOG "* Running makepkg -i on $ROOT/builds/$pkg-doc/PKGBUILD\n";
+ chdir "$ROOT/builds/$pkg-doc";
+ system( "test -f $pkg-*.tar.xz && rm $pkg-*.tar.xz" );
+ # TODO : catch error if makepkg fails
+- system( "makepkg -ci" );
++ system( "makepkg -i" );
+ }
+
+