summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2020-02-08 17:26:15 +0100
committerXZS2020-02-08 17:26:15 +0100
commit7d2b2eebe9122e783992f2e1d719330cab25da0b (patch)
tree6169ad18a0bbeaab3476364b01b8f9a6826a8955
parent5c4b72647505710a3bb77b0d90d3d54ae8ea496e (diff)
downloadaur-7d2b2eebe9122e783992f2e1d719330cab25da0b.tar.gz
restore compilation with Pacman 5.2
Since Pacman version 5.2.0, makepkg exits whenever any command in a pkgver function returns a non-zero exit code. A recent correction from the git-makepkg-templates [1] adapts to this, restoring correct processing of the PKGBUILD. As this concerns only the build process, not changing any of the resulting package content, the pkgrel is kept constant, to avoid triggering any unnecessary rebuild. [1]: https://github.com/dffischer/git-makepkg-templates/commit/d91fca9b16dd03bc0bf924dbd95dd24b06e232fe
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5248f31a98b0..5523456eaf3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ conflicts+=("$_gitname")
pkgver() {
cd ${_gitname:-$pkgname}
git describe --long --tags 2>/dev/null | sed 's/[^[:digit:]]*\(.\+\)-\([[:digit:]]\+\)-g\([[:xdigit:]]\{7\}\)/\1.r\2.g\3/;t;q1'
- [ ${PIPESTATUS[0]} -ne 0 ] && \
+ [ ${PIPESTATUS[0]} -eq 0 ] || \
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}