summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2020-02-05 23:35:49 +0100
committerXZS2022-09-13 14:08:00 +0200
commite59b19df77cea00391e9b2c08c088774d0e62cd4 (patch)
tree589331431a17d8030f7708f35eb672f0d509cf11
parent667feb1bfe4fe00deb025884432437f806112516 (diff)
downloadaur-e59b19df77cea00391e9b2c08c088774d0e62cd4.tar.gz
fix missing exclusion on pacman package listing
there is an assumption within the tllocalmgr script that the package name is of form 'texlive-local', which is used to filter out the list of tex packages so that we know which system (from archlinux repo) tex packages are actually installed. With this new package name, 'tllocalmgr-git', this is not excluded leading to a startup error.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--tllocalmgr-enhance.patch (renamed from tllocalmgr.patch)0
-rw-r--r--tllocalmgr-fix-texlive-local-match.patch13
4 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f921d0f9dd0..3100354d6efe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = texlive-localmanager-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
pkgver = v0.7.r3.gbbd8488
- pkgrel = 1
+ pkgrel = 2
url = https://git.archlinux.org/users/remy/texlive-localmanager.git/
arch = any
license = GPL
@@ -15,9 +15,11 @@ pkgbase = texlive-localmanager-git
provides = texlive-localmanager=v0.7.r3.gbbd8488
conflicts = texlive-localmanager
source = texlive-localmanager::git://git.archlinux.org/users/remy/texlive-localmanager.git
- source = tllocalmgr.patch
+ source = tllocalmgr-enhance.patch
+ source = tllocalmgr-fix-texlive-local-match.patch
sha256sums = SKIP
sha256sums = 22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236
+ sha256sums = a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7
pkgname = texlive-localmanager-git
diff --git a/PKGBUILD b/PKGBUILD
index 246ec845762e..2a8c52311c89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=texlive-localmanager-git
_pkgname="${pkgname%-git}"
pkgver=v0.7.r3.gbbd8488
-pkgrel=1
+pkgrel=2
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
url='https://git.archlinux.org/users/remy/texlive-localmanager.git/'
@@ -23,9 +23,11 @@ depends=('texlive-core>=2011'
makedepends=('git')
source=("${_pkgname}::git://git.archlinux.org/users/remy/texlive-localmanager.git"
- 'tllocalmgr.patch')
+ 'tllocalmgr-enhance.patch'
+ 'tllocalmgr-fix-texlive-local-match.patch')
sha256sums=('SKIP'
- '22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236')
+ '22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236'
+ 'a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7')
pkgver() {
cd $_pkgname
@@ -37,7 +39,11 @@ prepare() {
# enhances the tllocalmgr script a bit
# thanks: @sharethewisdom and @cobaltspace
- patch -p1 < "$srcdir/tllocalmgr.patch"
+ patch -p1 < "$srcdir/tllocalmgr-enhance.patch"
+
+ # fix missing exclusion of matches for texlive local packages
+ # thanks: @CaptainBern
+ patch -p1 < "$srcdir/tllocalmgr-fix-texlive-local-match.patch"
}
package() {
diff --git a/tllocalmgr.patch b/tllocalmgr-enhance.patch
index a949ea909313..a949ea909313 100644
--- a/tllocalmgr.patch
+++ b/tllocalmgr-enhance.patch
diff --git a/tllocalmgr-fix-texlive-local-match.patch b/tllocalmgr-fix-texlive-local-match.patch
new file mode 100644
index 000000000000..d6f707510ad4
--- /dev/null
+++ b/tllocalmgr-fix-texlive-local-match.patch
@@ -0,0 +1,13 @@
+diff --git a/tllocalmgr b/tllocalmgr
+index b947ed2..b8d75dc 100755
+--- a/tllocalmgr
++++ b/tllocalmgr
+@@ -140,7 +140,7 @@ chomp(my @pacman = `pacman -Qs ^texlive- | egrep ^local | cut -d'/' -f2`);
+ my @localpacman = grep { /^texlive-local-/ } @pacman;
+ # To have the standard collections we get rid of
+ # texlive-local-<pkg> and texlive-localmanager:
+-my @collpacman = grep { !/^texlive-local/ } @pacman;
++my @collpacman = grep { !/^(texlive-local|tllocalmgr)/ } @pacman;
+
+ if (@localpacman) {
+ foreach (@localpacman) {