summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Eisele2020-11-13 21:03:32 +0100
committerAlexander Eisele2020-11-13 21:03:32 +0100
commit560411dbe4cc5e7b0c098e9331d82984ef128cf8 (patch)
tree8ab97c14858886044a753738959e0e90bffb038a
downloadaur-560411dbe4cc5e7b0c098e9331d82984ef128cf8.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--texlive-pgfgantt.install14
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b709830eee5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlive-pgfgantt
+ pkgdesc = A LaTeX package that provides the ganttchart environment, which draws a Gantt chart within a TikZ picture.
+ pkgver = 5.0
+ pkgrel = 1
+ url = https://www.ctan.org/pkg/pgfgantt?lang=en
+ install = texlive-pgfgantt.install
+ arch = any
+ license = LPPL
+ depends = texlive-core
+ source = http://mirrors.ctan.org/graphics/pgf/contrib/pgfgantt.zip
+ sha256sums = 94644bc77cfc38e7d6062794e79a08d30b1835e690d846fb429826fe25f37df3
+
+pkgname = texlive-pgfgantt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3882af484ab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alexander Eisele <alexander@eiselecloud.de>
+
+# Based on https://github.com/flosse/aur-texlive-pgfgantt
+
+pkgname=texlive-pgfgantt
+pkgver=5.0
+pkgrel=1
+license=('LPPL')
+depends=('texlive-core')
+pkgdesc='A LaTeX package that provides the ganttchart environment, which draws a Gantt chart within a TikZ picture.'
+url='https://www.ctan.org/pkg/pgfgantt?lang=en'
+arch=('any')
+install=${pkgname}.install
+source=('http://mirrors.ctan.org/graphics/pgf/contrib/pgfgantt.zip')
+sha256sums=('94644bc77cfc38e7d6062794e79a08d30b1835e690d846fb429826fe25f37df3')
+
+build() {
+ cd "$srcdir/pgfgantt/"
+ latex "pgfgantt.ins"
+}
+package() {
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/pgfgantt
+ install -D -m644 $srcdir/pgfgantt/pgfgantt.sty $pkgdir/usr/share/texmf/tex/latex/pgfgantt/
+}
+
diff --git a/texlive-pgfgantt.install b/texlive-pgfgantt.install
new file mode 100644
index 000000000000..04c6dc5e6e43
--- /dev/null
+++ b/texlive-pgfgantt.install
@@ -0,0 +1,14 @@
+post_install() {
+ post_remove
+ echo "The file was installed in:"
+ kpsewhich pgfgantt.sty
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}