summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo-Guilbert2017-07-24 20:03:40 -0400
committerGabriel-Andrew Pollo-Guilbert2017-07-24 20:03:40 -0400
commit8c710671c788a1052722d642df785dd25f683cf6 (patch)
tree3d6cf5116508be567c9049cbb7e7051ed1e7ff6f
downloadaur-8c710671c788a1052722d642df785dd25f683cf6.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--texlive-slashbox.install16
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d07770ca7726
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = texlive-slashbox
+ pkgdesc = A LaTeX package for producing split cell.
+ pkgver = 1993.05.27
+ pkgrel = 1
+ url = https://ctan.org/pkg/slashbox
+ install = texlive-slashbox.install
+ arch = any
+ license = unknown
+ depends = texlive-core
+ source = http://mirrors.ctan.org/macros/latex/contrib/slashbox/slashbox.sty
+ source = http://mirrors.ctan.org/macros/latex/contrib/slashbox/slashbox.tex
+ md5sums = ce2190dc09125c3010b0dfd2226dd182
+ md5sums = f8479d69e1d4e5583adb36d224cc10b6
+
+pkgname = texlive-slashbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a046c660d9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Gabriel-Andrew Pollo Guilbert <gabriel14_wii@hotmail.com>
+
+pkgname=texlive-slashbox
+pkgver=1993.05.27
+pkgrel=1
+pkgdesc='A LaTeX package for producing split cell.'
+arch=('any')
+url='https://ctan.org/pkg/slashbox'
+license=('unknown')
+depends=('texlive-core')
+install='texlive-slashbox.install'
+source=('http://mirrors.ctan.org/macros/latex/contrib/slashbox/slashbox.sty'
+ 'http://mirrors.ctan.org/macros/latex/contrib/slashbox/slashbox.tex')
+md5sums=('ce2190dc09125c3010b0dfd2226dd182'
+ 'f8479d69e1d4e5583adb36d224cc10b6')
+
+package() {
+ mkdir -p "$pkgdir/usr/share/texmf/tex/latex/slashbox"
+
+ cp "$srcdir/slashbox.sty" "$pkgdir/usr/share/texmf/tex/latex/slashbox"
+ cp "$srcdir/slashbox.tex" "$pkgdir/usr/share/texmf/tex/latex/slashbox"
+}
+
+
diff --git a/texlive-slashbox.install b/texlive-slashbox.install
new file mode 100644
index 000000000000..3bfab79740b1
--- /dev/null
+++ b/texlive-slashbox.install
@@ -0,0 +1,16 @@
+post_install() {
+ post_remove
+ echo "The files was installed in:"
+ kpsewhich slashbox.sty
+ kpsewhich slashbox.tex
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ texhash
+}
+