summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob2017-01-19 17:44:29 +0100
committerJakob2017-01-19 17:44:29 +0100
commit064a4b7f3719be4ec898cb5da722011a23d2864a (patch)
tree587881df8707250865638197b3da2053a751ae0c
downloadaur-064a4b7f3719be4ec898cb5da722011a23d2864a.tar.gz
Add initial package build and install file.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--texlive-tikz-uml.install14
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc611c64b512
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = texlive-tikz-uml
+ pkgdesc = A LaTeX package for drawing UML diagrams using pgf/tikz
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://www.ensta-paristech.fr/~kielbasi/tikzuml/index.php?lang=en
+ install = texlive-tikz-uml.install
+ arch = any
+ license = GPL
+ depends = texlive-core
+ source = http://perso.ensta-paristech.fr/~kielbasi/tikzuml/var/files/src/tikzuml-v1.0-2016-03-29.tbz
+ md5sums = 8065a79c8cdf6fc99251d569dbaa65ec
+
+pkgname = texlive-tikz-uml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b63dd9f31db3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Original author: Nicolas Kielbasiewicz (nicolas.kielbasiewicz@ensta-paristech.fr)
+# Maintainer: Jakob Jungreithmeir <https://aur.archlinux.org/account/Acrypter>
+# Last edited: 17th January 2017
+
+pkgname=texlive-tikz-uml
+pkgver=1.0
+pkgrel=1
+_reldate=2016-03-29
+license=('GPL')
+depends=('texlive-core')
+pkgdesc="A LaTeX package for drawing UML diagrams using pgf/tikz"
+url="http://www.ensta-paristech.fr/~kielbasi/tikzuml/index.php?lang=en"
+arch=('any')
+install=texlive-tikz-uml.install
+source=(http://perso.ensta-paristech.fr/~kielbasi/tikzuml/var/files/src/tikzuml-v${pkgver}-${_reldate}.tbz)
+md5sums=('8065a79c8cdf6fc99251d569dbaa65ec')
+
+package() {
+ install -Dm644 "$srcdir/tikzuml-v${pkgver}-${_reldate}/tikz-uml.sty" "$pkgdir/usr/share/texmf-dist/tex/latex/tikz-uml/tikz-uml.sty"
+}
diff --git a/texlive-tikz-uml.install b/texlive-tikz-uml.install
new file mode 100644
index 000000000000..aee37979c956
--- /dev/null
+++ b/texlive-tikz-uml.install
@@ -0,0 +1,14 @@
+post_install() {
+ post_remove
+ echo "The file was installed in:"
+ kpsewhich tikz-uml.sty
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ echo "Upgrading package database..."
+ mktexlsr
+}