summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben De Smet2016-10-28 14:39:05 +0200
committerRuben De Smet2016-10-28 14:42:20 +0200
commit3822ad80b37862474744d6483f9d84fa1996e843 (patch)
treee7e2c2dd73c750e58eb5069690fcbc4557a53672
downloadaur-3822ad80b37862474744d6483f9d84fa1996e843.tar.gz
Initial package.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD47
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b973afe9cad6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Fri Oct 28 12:40:35 UTC 2016
+pkgbase = texlive-vub
+ pkgdesc = Provides the titlepage and style elements for the Vrije Universiteit Brussel.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://huisstijl.vub.ac.be/
+ arch = any
+ license = LPPL
+ makedepends = binutils
+ depends = texlive-core
+ depends = tex-gyre-fonts
+ options = !emptydirs
+ source = https://gitlab.com/rubdos/texlive-vub/repository/archive.tar.bz2?ref=v1.1.0
+ sha512sums = 877551845ed45de25f8541ad21bca07a06faf3a116cf1288e6abd784c3220934dbc68daae55f5a7b6d4ddd0616278f21bccabca9a032345daf794e478a2a8bad
+
+pkgname = texlive-vub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..330d81e2efc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Ruben De Smet <ruben dot de dot smet at rubdos dot be>
+
+pkgname='texlive-vub'
+pkgver="1.1.0"
+pkgrel=1
+pkgdesc='Provides the titlepage and style elements for the Vrije Universiteit Brussel.'
+url='https://huisstijl.vub.ac.be/'
+license=(
+ 'LPPL'
+)
+source=(
+ "https://gitlab.com/rubdos/texlive-vub/repository/archive.tar.bz2?ref=v${pkgver}"
+)
+sha512sums=(
+ '877551845ed45de25f8541ad21bca07a06faf3a116cf1288e6abd784c3220934dbc68daae55f5a7b6d4ddd0616278f21bccabca9a032345daf794e478a2a8bad'
+)
+arch=(
+ 'any'
+)
+depends=(
+ 'texlive-core'
+ 'tex-gyre-fonts'
+)
+makedepends=(
+ 'binutils'
+)
+checkdepends=(
+)
+options=(
+ '!emptydirs'
+)
+
+package() {
+ dir=$srcdir/texlive-vub-v1.1.0-070b96bbe5e02530c7984266679aecf477081f23
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/vub
+ cp $dir/vub_logo_cmyk.pdf $dir/vub.sty $pkgdir/usr/share/texmf/tex/latex/vub
+}
+
+post_install() {
+ mktexsr
+}
+
+post_remove() {
+ mktexlsr
+}
+
+# vim: tabstop=1 expandtab