summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 22:58:28 +0200
committerAlbert Graef2015-06-13 22:58:28 +0200
commit40fe4f0f8271f83911698190762933c538d775aa (patch)
treead791504ce58ce27fa69b4b0c7e30a72a15f0308
downloadaur-40fe4f0f8271f83911698190762933c538d775aa.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
3 files changed, 58 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..84b4421d3794
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = texmacs-pure
+ pkgdesc = Pure plugin for GNU TeXmacs
+ pkgver = 0.64
+ pkgrel = 1
+ url = https://bitbucket.org/purelang/pure-lang/wiki/TeXmacs
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-math
+ license = LGPL3
+ depends = texmacs
+ depends = pure
+ source = https://bitbucket.org/purelang/pure-lang/downloads/pure-0.64.tar.gz
+ md5sums = 399b0a5cb6bbf0042ce42f9a857e332e
+
+pkgname = texmacs-pure
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..84b4421d3794
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = texmacs-pure
+ pkgdesc = Pure plugin for GNU TeXmacs
+ pkgver = 0.64
+ pkgrel = 1
+ url = https://bitbucket.org/purelang/pure-lang/wiki/TeXmacs
+ arch = i686
+ arch = x86_64
+ groups = pure-complete
+ groups = pure-math
+ license = LGPL3
+ depends = texmacs
+ depends = pure
+ source = https://bitbucket.org/purelang/pure-lang/downloads/pure-0.64.tar.gz
+ md5sums = 399b0a5cb6bbf0042ce42f9a857e332e
+
+pkgname = texmacs-pure
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af3eecaa7eea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alastair Pharo <asppsa at gmail dot com>
+# Contributor: Alain Kalker <a.c.kalker at gmail dot com>
+
+pkgname=texmacs-pure
+pkgver=0.64
+pkgrel=1
+pkgdesc="Pure plugin for GNU TeXmacs"
+arch=("i686" "x86_64")
+license=('LGPL3')
+url="https://bitbucket.org/purelang/pure-lang/wiki/TeXmacs"
+depends=('texmacs' "pure")
+groups=(pure-complete pure-math)
+source=("https://bitbucket.org/purelang/pure-lang/downloads/pure-$pkgver.tar.gz")
+md5sums=('399b0a5cb6bbf0042ce42f9a857e332e')
+
+build() {
+ cd $srcdir/pure-$pkgver
+ ./configure --prefix=/usr
+}
+
+package() {
+ cd $srcdir/pure-$pkgver
+ make DESTDIR=$pkgdir tmdir=/usr/share/TeXmacs install-tm
+}