summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2018-07-15 22:42:29 -0300
committerMarcos Heredia2018-07-15 22:42:29 -0300
commit849a44b9d8785b18384ab4dbd98e8952d913079e (patch)
treef221f5096e91650722d6a1f92afc202e4f6764f4
parent31c16916e3c8f1a3a0e4971969f7aefbf81fbd59 (diff)
downloadaur-849a44b9d8785b18384ab4dbd98e8952d913079e.tar.gz
Update 1.99.7-1
-rw-r--r--texmacs-fix-linking.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/texmacs-fix-linking.patch b/texmacs-fix-linking.patch
new file mode 100644
index 000000000000..06a63f5365e8
--- /dev/null
+++ b/texmacs-fix-linking.patch
@@ -0,0 +1,18 @@
+--- texmacs/src/CMakeLists.txt.orig 2018-07-14 09:20:14.114218215 +0000
++++ texmacs/src/CMakeLists.txt 2018-07-14 09:21:07.651031679 +0000
+@@ -1,6 +1,8 @@
+
+ add_library(texmacs_body ${TeXmacs_All_SRCS})
+
++target_link_libraries (texmacs_body ${TeXmacs_Libraries})
++
+ add_executable (${TeXmacs_binary_name}
+ ./Texmacs/Texmacs/texmacs.cpp
+ )
+@@ -19,4 +21,4 @@
+ RUNTIME_OUTPUT_DIRECTORY ${TEXMACS_BINARY_DIR}
+ )
+
+-install(TARGETS ${TeXmacs_binary_name} DESTINATION lib/texmacs/TeXmacs/bin)
+\ No newline at end of file
++install(TARGETS ${TeXmacs_binary_name} DESTINATION lib/texmacs/TeXmacs/bin)