summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcos Heredia2018-07-15 22:43:39 -0300
committerMarcos Heredia2018-07-15 22:43:39 -0300
commitf427c4d474a71bbf74761f559866e21c95b5e932 (patch)
treefa4aafc5a0b2bd39d9b24f466ab8ebc20fe60c2e
parent849a44b9d8785b18384ab4dbd98e8952d913079e (diff)
downloadaur-f427c4d474a71bbf74761f559866e21c95b5e932.tar.gz
Update 1.99.7-1
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD122
-rw-r--r--texmacs.desktop2
3 files changed, 68 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2f7a2a02e26..0ba9d49c0310 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,38 @@
# Generated by mksrcinfo v8
-# Sun Oct 2 21:52:03 UTC 2016
+# Mon Jul 16 01:43:23 UTC 2018
pkgbase = texmacs-qt
- pkgdesc = WYSIWYG Qt4 editor and graphical frontend to various CASes
- pkgver = 1.99.5
+ pkgdesc = WYSIWYG Qt5 editor and graphical frontend to various CASes
+ pkgver = 1.99.7
pkgrel = 1
url = http://texmacs.org/
- install = texmacs-qt.install
- arch = i686
arch = x86_64
license = GPL3
makedepends = ghostscript
- depends = qt4
+ makedepends = cmake
+ depends = qt5-base
depends = guile1.8
- depends = cairo
- depends = freetype2
- depends = imlib2
+ depends = icu
+ depends = libsystemd
+ depends = libtool
depends = perl
depends = python2
- depends = libxext
- depends = sqlite
- depends = desktop-file-utils
- depends = shared-mime-info
- depends = gtk-update-icon-cache
optdepends = texlive-core: TeX-fonts
- optdepends = gawk: conversion of some files
optdepends = transfig: convert images using fig2ps
+ optdepends = gawk: conversion of some files
optdepends = ghostscript: rendering ps files
optdepends = imagemagick: convert images
optdepends = aspell: spell checking
+ provides = texmacs
conflicts = texmacs
options = !emptydirs
- source = http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-1.99.5-src.tar.gz
+ source = http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-1.99.7-src.tar.gz
+ source = texmacs-fix-linking.patch
source = http://www.texmacs.org/Images/tm_gnu1b.png
source = texmacs.desktop
- md5sums = c9d6ddbd2c528f6b263f316df0a55ff1
+ md5sums = 39e6502cdb959b4bf6faea4764608809
+ md5sums = bc683a7c6b961bcf6a41bdb5f35e488f
md5sums = 48c15c09000cc38728d847c3a8ffabc0
- md5sums = a1856736b4defd6f3a46cf608b108ef1
+ md5sums = 9b8210c9b1414919da07d101f878f2c9
pkgname = texmacs-qt
diff --git a/PKGBUILD b/PKGBUILD
index e1c5d3e18bc0..32ceebb57ed6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,93 +1,75 @@
-# Contributor: Adam Dariusz Szkoda <adaszko at gmail dot com>
-# Contributor: Egon Geerardyn <egon.geerardyn@gmail.com>
-# Maintainer : Marcos Heredia <chelqo@gmail.com>
-
-# some parts taken from PKGBUILD official ArchLinux
-
pkgname=texmacs-qt
-pkgver=1.99.5
+pkgver=1.99.7
pkgrel=1
-pkgdesc="WYSIWYG Qt4 editor and graphical frontend to various CASes"
-arch=('i686' 'x86_64')
+pkgdesc="WYSIWYG Qt5 editor and graphical frontend to various CASes"
+arch=('x86_64')
url='http://texmacs.org/'
license=('GPL3')
-depends=('qt4' 'guile1.8' 'cairo' 'freetype2' 'imlib2'
- 'perl' 'python2' 'libxext' 'sqlite'
- 'desktop-file-utils' 'shared-mime-info' 'gtk-update-icon-cache')
-optdepends=('texlive-core: TeX-fonts'
- 'gawk: conversion of some files'
- 'transfig: convert images using fig2ps'
- 'ghostscript: rendering ps files'
- 'imagemagick: convert images'
- 'aspell: spell checking')
-makedepends=('ghostscript')
-options=('!emptydirs')
+depends=('qt5-base' 'guile1.8' 'icu' 'libsystemd' 'libtool' 'perl' 'python2')
+makedepends=('ghostscript' 'cmake')
+optdepends=(
+ 'texlive-core: TeX-fonts' # Yes, optional: http://www.texmacs.org/tmweb/download/packaging.en.html
+ 'transfig: convert images using fig2ps'
+ 'gawk: conversion of some files'
+ 'ghostscript: rendering ps files'
+ 'imagemagick: convert images'
+ 'aspell: spell checking')
+provides=('texmacs')
conflicts=('texmacs')
-install=${pkgname}.install
+options=('!emptydirs')
source=("http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-$pkgver-src.tar.gz"
+ 'texmacs-fix-linking.patch'
'http://www.texmacs.org/Images/tm_gnu1b.png'
'texmacs.desktop')
-md5sums=('c9d6ddbd2c528f6b263f316df0a55ff1'
+md5sums=('39e6502cdb959b4bf6faea4764608809'
+ 'bc683a7c6b961bcf6a41bdb5f35e488f'
'48c15c09000cc38728d847c3a8ffabc0'
- 'a1856736b4defd6f3a46cf608b108ef1')
+ '9b8210c9b1414919da07d101f878f2c9')
prepare() {
- cd ${srcdir}/TeXmacs-${pkgver}-src
+ msg "### patch"
+ cd ${srcdir}/TeXmacs-${pkgver}-src
- sed -i 's/env python/env python2/' \
- plugins/{mathematica/bin/realpath.py,python/bin/tm_python,sage/bin/tm_sage} \
- TeXmacs/misc/inkscape_extension/texmacs_reedit.py
- sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
- sed -i '/^LDPATH/d' src/makefile.in
+ sed -i 's/env python/env python2/' \
+ plugins/{mathematica/bin/realpath.py,python/bin/tm_python,sage/bin/tm_sage} \
+ TeXmacs/misc/inkscape_extension/texmacs_reedit.py
+ sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
- autoreconf -vi
- sed -i -e 's/guile18-config/guile-config1.8/g' configure
- sed -i -e 's/guile18/guile1.8/g' configure
- sed -i -e 's|#include <libguile18.h>|#include <guile/gh.h>|g' src/Scheme/Guile/guile_tm.hpp
-
- sed -i '/update-mime-database/d' Makefile.in
- sed -i '/gtk-update-icon-cache/d' Makefile.in
- sed -i '\/icons\/gnome 2>\/dev\/null/d' Makefile.in
-
- find -name '.*.d' -o -name '.*.cpp' -exec rm {} \;
+ patch -p1 -i ../texmacs-fix-linking.patch
}
build() {
- cd ${srcdir}/TeXmacs-${pkgver}-src
+ cd TeXmacs-${pkgver}-src
- export LDFLAGS="$LDFLAGS -lz"
- QMAKE=/usr/bin/qmake-qt4 \
- MOC=/usr/bin/moc-qt4 \
- UIC=/usr/bin/uic-qt4 \
- RCC=/usr/lib/qt4/bin/rcc \
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --libexecdir=/usr/lib \
- --enable-pdf-renderer \
- --enable-optimize \
- --with-imlib2 \
- --enable-guile2=no \
- --with-qt
- make || return 1
+ [ -d build ] && rm -rv build
+ mkdir -p build
+ cd build
-# --with-freetype \
-# --with-sqlite3=yes \
+ msg "### configure"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGUILECONFIG_EXECUTABLE=/usr/bin/guile-config1.8
+ msg "### make"
+ make
}
package() {
- cd ${srcdir}/TeXmacs-${pkgver}-src
- make DESTDIR=${pkgdir} install
- sed -i 's|${prefix}|/usr|' ${pkgdir}/usr/bin/fig2ps
+ cd TeXmacs-${pkgver}-src/build
- _appdir=${pkgdir}/usr/share/applications
- _pngdir=${pkgdir}/usr/share/pixmaps
- _docdir=${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
- _licdir=${pkgdir}/usr/share/licenses/${pkgname}
- install -dm 755 ${_appdir} ${_pngdir} ${_docdir} ${_licdir}
- install -Dpm 0644 ${srcdir}/../texmacs.desktop ${_appdir}/
- install -Dpm 0644 ${srcdir}/../tm_gnu1b.png ${_pngdir}/texmacs.png
- install -Dpm 0644 COMPILE COPYING LICENSE TODO TeXmacs/INSTALL TeXmacs/README TeXmacs/TEX_FONTS ${_docdir}/
- cd ${_licdir} ; ln -s ../../TeXmacs/LICENSE .
-}
+ msg "### install"
+ make DESTDIR=${pkgdir} install
+ sed -i 's|${prefix}|/usr|' "${pkgdir}/usr/bin/fig2ps"
+ sed -e 's|\@CONFIG_LIB_PATH\@|LD_LIBRARY_PATH|g' -i "$pkgdir"/usr/bin/texmacs
+ cd ..
+ _appdir=${pkgdir}/usr/share/applications
+ _pngdir=${pkgdir}/usr/share/pixmaps
+ _docdir=${pkgdir}/usr/share/doc/${pkgname}-${pkgver}
+ _licdir=${pkgdir}/usr/share/licenses/${pkgname}
+ install -dm 755 ${_appdir} ${_pngdir} ${_docdir} ${_licdir}
+ install -Dpm 0644 ${startdir}/texmacs.desktop ${_appdir}/
+ install -Dpm 0644 ${startdir}/tm_gnu1b.png ${_pngdir}/texmacs.png
+ install -Dpm 0644 COMPILE COPYING LICENSE TODO TeXmacs/INSTALL TeXmacs/README TeXmacs/TEX_FONTS ${_docdir}/
+ cd ${_licdir} ; ln -s ../../TeXmacs/LICENSE .
+}
diff --git a/texmacs.desktop b/texmacs.desktop
index 7685f831c54b..641787ccd77f 100644
--- a/texmacs.desktop
+++ b/texmacs.desktop
@@ -8,4 +8,4 @@ Exec=texmacs
Icon=texmacs.png
Terminal=false
Type=Application
-Categories=Science;Math;
+Categories=Education;Science;Math;