summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Straube2017-07-28 19:20:16 +0200
committerMichael Straube2017-07-28 19:20:16 +0200
commit1c04927126ea6d621a285eaeb921d4ca0ef3a6b9 (patch)
tree169007af94cf86a9448b0469d9f1a4b75513a867
downloadaur-1c04927126ea6d621a285eaeb921d4ca0ef3a6b9.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0dd29ba0863
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = text2pdf
+ pkgdesc = Converts text files to PDF on the command line
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://www.eprg.org/pdfcorner/text2pdf/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc
+ source = http://www.eprg.org/pdfcorner/text2pdf/text2pdf.c
+ source = http://www.eprg.org/pdfcorner/text2pdf/text2pdf.1
+ sha256sums = a11d07787f4e9febddd96888ff319c5c527a5436d27c75a4bac16d11fcf45600
+ sha256sums = 5f21feda206bd26df11938e1ff9d9c246e04a6c250225d5561e0242f38af68fe
+
+pkgname = text2pdf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23f73606982e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Straube <straubem@gmx.de>
+
+pkgname=text2pdf
+pkgver=1.1
+pkgrel=1
+pkgdesc='Converts text files to PDF on the command line'
+arch=('i686' 'x86_64')
+url='http://www.eprg.org/pdfcorner/text2pdf/'
+license=('custom')
+depends=('glibc')
+source=('http://www.eprg.org/pdfcorner/text2pdf/text2pdf.c'
+ 'http://www.eprg.org/pdfcorner/text2pdf/text2pdf.1')
+sha256sums=('a11d07787f4e9febddd96888ff319c5c527a5436d27c75a4bac16d11fcf45600'
+ '5f21feda206bd26df11938e1ff9d9c246e04a6c250225d5561e0242f38af68fe')
+
+prepare() {
+ head -n 24 text2pdf.c > LICENSE
+}
+
+build() {
+ gcc $CFLAGS -v -o text2pdf text2pdf.c
+}
+
+package() {
+ install -Dm755 text2pdf "$pkgdir"/usr/bin/text2pdf
+ install -Dm644 text2pdf.1 "$pkgdir"/usr/share/man/man1/text2pdf.1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}