summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2015-06-14 12:39:05 +0800
committerDario Giovannetti2015-06-14 12:39:05 +0800
commit8e89cf7befe1774ec3d3c4089dcdbf30d31a76a0 (patch)
tree9b3d644f9ab6f4403c490313934194fb12ae3747
downloadaur-8e89cf7befe1774ec3d3c4089dcdbf30d31a76a0.tar.gz
Init commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b519665b500
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textadept-common-git
+ pkgdesc = Some functions, key commands and modifications that change Textadept's default behaviour
+ pkgver = 20150118.8de20fb
+ pkgrel = 1
+ url = https://rgieseke.github.io/ta-common/
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = textadept
+ source = https://github.com/rgieseke/ta-common/archive/master.tar.gz
+ sha256sums = SKIP
+
+pkgname = textadept-common-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cfb0ebba68c1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/*.pkg.tar.xz
+/*.src.tar.gz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..154234d91b22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Dario Giovannetti <dev at dariogiovannetti dot net>
+
+pkgname='textadept-common-git'
+pkgver=20150118.8de20fb
+pkgrel=1
+pkgdesc="Some functions, key commands and modifications that change Textadept's default behaviour"
+arch=('any')
+url='https://rgieseke.github.io/ta-common/'
+license=('MIT')
+depends=('textadept')
+makedepends=('git')
+source=("https://github.com/rgieseke/ta-common/archive/master.tar.gz")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd 'ta-common-master'
+ echo $(date +%Y%m%d).$(git ls-remote git://github.com/rgieseke/ta-common.git master | cut -c -7)
+}
+
+package() {
+ mkdir -p "${pkgdir}/opt/textadept/modules/common"
+ cp -r "ta-common-master/." "${pkgdir}/opt/textadept/modules/common/"
+}