summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthreeoh60002024-01-01 22:07:16 +0000
committerthreeoh60002024-01-01 22:07:16 +0000
commitaa85fa5dffb7f43b13f65c82ba619863fa5366c4 (patch)
tree4c6b341ba7deab83061b81932b98e94306871d07
downloadaur-aa85fa5dffb7f43b13f65c82ba619863fa5366c4.tar.gz
Add pkgbuild
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32c3072515d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = textbar-git
+ pkgdesc = Text status bar for X11
+ pkgver = db4159c546
+ pkgrel = 1
+ url = https://gitea.itycodes.org/itycodes/textbar
+ arch = x86_64
+ license = BSD-3-Clause
+ depends = gcc>=11.0.0,cairo>=1.17.8,libx11>=1.8.0
+ provides = textbar
+ conflicts = textbar
+ source = https://gitea.itycodes.org/itycodes/textbar/archive/db4159c5469d763c3b8c901d2bd0559a9d03129a.tar.gz
+ sha256sums = b2d5b985a697dfbf09059084d030ac8ccf6b1a92791f7877bc9ba109d0a8e43b
+
+pkgname = textbar-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..968808912dbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: threeoh6000 <master@colean.cc>
+pkgname="textbar-git"
+pkgver="db4159c546"
+pkgrel=1
+pkgdesc="Text status bar for X11"
+arch=("x86_64")
+url="https://gitea.itycodes.org/itycodes/textbar"
+license=("BSD-3-Clause")
+depends=("gcc>=11.0.0","cairo>=1.17.8","libx11>=1.8.0")
+source=("https://gitea.itycodes.org/itycodes/textbar/archive/db4159c5469d763c3b8c901d2bd0559a9d03129a.tar.gz")
+sha256sums=("b2d5b985a697dfbf09059084d030ac8ccf6b1a92791f7877bc9ba109d0a8e43b")
+provides=("textbar")
+conflicts=("textbar")
+
+build() {
+ cd "textbar"
+ ./compile.sh
+}
+
+package() {
+ cd "textbar"
+ mkdir -p "$pkgdir/usr/bin"
+ cp main.o "$pkgdir/usr/bin/textbar"
+}