summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-11-22 17:55:39 +0100
committerMuflone2015-11-22 17:55:39 +0100
commit9a4251b4f81696485793422d4bb5550906796f2e (patch)
tree8ae1136b15eb51f67b67816394ad628c3ff297d9
downloadaur-9a4251b4f81696485793422d4bb5550906796f2e.tar.gz
New package textdataparser 0.1.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
-rw-r--r--textdataparser.install12
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69428e2908a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = textdataparser
+ pkgdesc = Graphic interface to view text data files with definitions
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://www.muflone.com/textdataparser/
+ install = textdataparser.install
+ arch = any
+ license = GPL2
+ depends = gtk3
+ depends = gobject-introspection
+ depends = python2-xdg
+ depends = python2-gobject
+ depends = gtk-update-icon-cache
+ source = textdataparser-0.1.0.tar.gz::https://github.com/muflone/textdataparser/archive/0.1.0.tar.gz
+ sha256sums = cb7f8bb3969c5f16933b7ea1ab5e046c9f6b09ba66afb095981e5e55723cec69
+
+pkgname = textdataparser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1142bdd3eb99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=textdataparser
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Graphic interface to view text data files with definitions"
+url="http://www.muflone.com/textdataparser/"
+arch=('any')
+license=('GPL2')
+depends=('gtk3' 'gobject-introspection' 'python2-xdg' 'python2-gobject' 'gtk-update-icon-cache')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('cb7f8bb3969c5f16933b7ea1ab5e046c9f6b09ba66afb095981e5e55723cec69')
+install="${pkgname}.install"
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python2 setup.py install --optimize=1 --root "${pkgdir}"
+}
+
diff --git a/textdataparser.install b/textdataparser.install
new file mode 100644
index 000000000000..736528a49255
--- /dev/null
+++ b/textdataparser.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q /usr/share/icons/hicolor/
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+