summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortheunpleasantowl2018-08-24 23:52:48 -0400
committertheunpleasantowl2018-08-24 23:52:48 -0400
commit9036b75680b37202b9ad75ab8af8c4f9b1e873af (patch)
tree9d486373b7082b5293d7de7f73b102253cb9d077
downloadaur-9036b75680b37202b9ad75ab8af8c4f9b1e873af.tar.gz
Stage for AUR
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD37
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad92dde875f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = textedit-classic.app
+ pkgdesc = A text editor with font, color, and style capabilities for GNUstep
+ pkgver = 4.0+20061029
+ pkgrel = 1
+ url = http://www.nongnu.org/backbone/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-apps
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ conflicts = textedit.app
+ source = http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029.orig.tar.gz
+ source = http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029-3.5.diff.gz
+ sha256sums = 3abb2ae8142edc64feb8b44dec3d449f6c72a0059253ab979ec335b8766b03dd
+ sha256sums = d9cc1881003e62e1f1997566b5885ae766ad53905c9870ec62712b4d1164fb33
+
+pkgname = textedit-classic.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c31b0bde44d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=TextEdit
+pkgname=textedit-classic.app
+pkgrel=1
+pkgver=4.0+20061029
+pkgdesc='A text editor with font, color, and style capabilities for GNUstep'
+arch=('i686' 'x86_64' 'armv7h')
+url='http://www.nongnu.org/backbone/'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+conflicts=('textedit.app')
+source=("http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029.orig.tar.gz"
+ "http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029-3.5.diff.gz")
+sha256sums=('3abb2ae8142edc64feb8b44dec3d449f6c72a0059253ab979ec335b8766b03dd'
+ 'd9cc1881003e62e1f1997566b5885ae766ad53905c9870ec62712b4d1164fb33')
+
+prepare() {
+ cd "textedit.app-$pkgver"
+ for patch in ../*.diff; do
+ patch < $patch
+ done
+}
+
+build() {
+ cd "textedit.app-$pkgver"
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd "textedit.app-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+}