summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHibiki2019-08-05 23:19:36 -0400
committerHibiki2019-08-05 23:19:36 -0400
commita098acb8350d40ebe14369dafe9fecf234374313 (patch)
tree5652bec1c61209963f405d5a210166a1a2fbd71f
parent4a43cb18cc899716f7c28a70d70fdf69ead577fe (diff)
downloadaur-a098acb8350d40ebe14369dafe9fecf234374313.tar.gz
Change Sources to Gentoo
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad92dde875f3..f4e7b06bba0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,10 +14,12 @@ pkgbase = textedit-classic.app
depends = gnustep-gui
depends = gnustep-back
conflicts = textedit.app
- source = http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029.orig.tar.gz
- source = http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029-3.5.diff.gz
- sha256sums = 3abb2ae8142edc64feb8b44dec3d449f6c72a0059253ab979ec335b8766b03dd
- sha256sums = d9cc1881003e62e1f1997566b5885ae766ad53905c9870ec62712b4d1164fb33
+ source = https://mirrors.lug.mtu.edu/gentoo/distfiles/textedit-0.95_pre20100427.tar.gz
+ source = https://gitweb.gentoo.org/repo/gentoo.git/plain/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch
+ source = https://gitweb.gentoo.org/repo/gentoo.git/plain/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = textedit-classic.app
diff --git a/PKGBUILD b/PKGBUILD
index ed3a52dec067..fe53235535d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=TextEdit
pkgname=textedit-classic.app
pkgrel=1
-pkgver=4.0+20061029
+pkgver=4.0+20061029
pkgdesc='A text editor with font, color, and style capabilities for GNUstep'
arch=('i686' 'x86_64' 'armv7h')
url='http://www.nongnu.org/backbone/'
@@ -12,26 +12,26 @@ groups=('gnustep-apps')
depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
makedepends=('gcc-objc' 'gnustep-make')
conflicts=('textedit.app')
-source=("http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029.orig.tar.gz"
- "http://http.debian.net/debian/pool/main/t/textedit.app/textedit.app_4.0+20061029-3.5.diff.gz")
-sha256sums=('3abb2ae8142edc64feb8b44dec3d449f6c72a0059253ab979ec335b8766b03dd'
- 'd9cc1881003e62e1f1997566b5885ae766ad53905c9870ec62712b4d1164fb33')
+source=("https://mirrors.lug.mtu.edu/gentoo/distfiles/textedit-0.95_pre20100427.tar.gz"
+"https://gitweb.gentoo.org/repo/gentoo.git/plain/gnustep-apps/textedit/files/textedit-0.95_pre20100427-gcc47.patch"
+"https://gitweb.gentoo.org/repo/gentoo.git/plain/gnustep-apps/textedit/files/textedit-0.95_pre20100427-nsinvalidargument.patch")
+sha256sums=("SKIP" "SKIP" "SKIP")
prepare() {
- cd "textedit.app-$pkgver"
- for patch in ../*.diff; do
+ cd $_pkgname
+ for patch in ../*.patch; do
patch < $patch
done
}
build() {
- cd "textedit.app-$pkgver"
+ cd $_pkgname
export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
make
}
package() {
- cd "textedit.app-$pkgver"
+ cd $_pkgname
make DESTDIR="$pkgdir" install
install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
}