summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-07-26 14:35:49 +0200
committerStefan Husmann2015-07-26 14:35:49 +0200
commit7911e1471b85064e45ca9acb0e9665bad0e7a378 (patch)
treee8ef96dffbb6d12688462547e213a83fb7e65823
downloadaur-7911e1471b85064e45ca9acb0e9665bad0e7a378.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE.txt28
-rw-r--r--PKGBUILD21
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a508479d11d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = textext
+ pkgdesc = An inkscape extension which lets you add LaTeX equations to your drawings
+ pkgver = 0.4.4
+ pkgrel = 3
+ url = http://pav.iki.fi/software/textext/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ depends = inkscape
+ depends = texlive-core
+ depends = python2-lxml
+ depends = pdf2svg
+ source = http://pav.iki.fi/software/textext/textext-0.4.4.tar.gz
+ source = LICENSE.txt
+ md5sums = 5dbb18bf762565196f8ac1f68f8607e3
+ md5sums = 91da7de463147c1c78b1c2e6f24da380
+
+pkgname = textext
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..69f5d47204ec
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,28 @@
+Copyright (c) 2007-2008 Pauli Virtanen.
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+ a. Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+ b. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ c. Neither the name of the copyright holder nor the names of the contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c0de06891dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Joel Schaerer <joel.schaerer@laposte.net>
+pkgname=textext
+pkgver=0.4.4
+pkgrel=3
+pkgdesc="An inkscape extension which lets you add LaTeX equations to your drawings"
+arch=('i686' 'x86_64')
+license=('BSD')
+url="http://pav.iki.fi/software/textext/"
+depends=('inkscape' 'texlive-core' 'python2-lxml' 'pdf2svg')
+source=(http://pav.iki.fi/software/textext/$pkgname-$pkgver.tar.gz LICENSE.txt)
+md5sums=('5dbb18bf762565196f8ac1f68f8607e3'
+ '91da7de463147c1c78b1c2e6f24da380')
+package() {
+ cd "$srcdir"
+ install -Dm 644 LICENSE.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ install -Dm 755 textext.py \
+ "${pkgdir}/usr/share/inkscape/extensions/textext.py"
+ install -Dm 644 textext.inx \
+ "${pkgdir}/usr/share/inkscape/extensions/textext.inx"
+ }