summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-03-06 06:34:15 +0100
committerhaawda2018-03-06 06:34:15 +0100
commitdb46a4a004afe7f4029a38cb70f6228bae4379c7 (patch)
treec4b921a71a0f579d1cfd323e6c8844fd610bff54
parent8f371cba5e4879d66784588ad357855165357168 (diff)
downloadaur-db46a4a004afe7f4029a38cb70f6228bae4379c7.tar.gz
rewritten PKGBUILD
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE.txt28
-rw-r--r--PKGBUILD29
3 files changed, 19 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d59ba535e574..26fe9bc33af7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = textext
pkgdesc = An inkscape extension which lets you add LaTeX equations to your drawings
- pkgver = 0.4.4
- pkgrel = 6
+ pkgver = 0.7
+ pkgrel = 1
url = http://pav.iki.fi/software/textext/
arch = any
license = custom:BSD
@@ -10,10 +10,8 @@ pkgbase = textext
depends = python2
optdepends = pdf2svg
optdepends = pygtk
- source = http://pav.iki.fi/_downloads/textext-0.4.4.tar.gz
- source = LICENSE.txt
- md5sums = 5dbb18bf762565196f8ac1f68f8607e3
- md5sums = 91da7de463147c1c78b1c2e6f24da380
+ source = https://bitbucket.org/pitgarbe/textext/downloads/TexText-Linux-0.7.tgz
+ md5sums = ddeddf0f4bb3af5d497389c913ba0145
pkgname = textext
diff --git a/LICENSE.txt b/LICENSE.txt
deleted file mode 100644
index 69f5d47204ec..000000000000
--- a/LICENSE.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-Copyright (c) 2007-2008 Pauli Virtanen.
-
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
- a. Redistributions of source code must retain the above copyright notice,
- this list of conditions and the following disclaimer.
- b. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in the
- documentation and/or other materials provided with the distribution.
- c. Neither the name of the copyright holder nor the names of the contributors
- may be used to endorse or promote products derived from this software
- without specific prior written permission.
-
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index da73549f5bd3..88659532a306 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,29 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=textext
-pkgver=0.4.4
-pkgrel=6
+pkgver=0.7
+pkgrel=1
pkgdesc="An inkscape extension which lets you add LaTeX equations to your drawings"
arch=('any')
license=('custom:BSD')
url="http://pav.iki.fi/software/textext/"
depends=('inkscape' 'texlive-core' 'python2')
optdepends=('pdf2svg' 'pygtk')
-source=("http://pav.iki.fi/_downloads/$pkgname-$pkgver.tar.gz" LICENSE.txt)
-md5sums=('5dbb18bf762565196f8ac1f68f8607e3'
- '91da7de463147c1c78b1c2e6f24da380')
+source=("https://bitbucket.org/pitgarbe/textext/downloads/TexText-Linux-0.7.tgz")
+md5sums=('ddeddf0f4bb3af5d497389c913ba0145')
prepare() {
- sed -i '1s|python\>|python2|' textext.py
+ sed -i '1s|python\>|python2|' $pkgname-$pkgver-linux/extension/textext.py
}
package() {
- cd "$srcdir"
- install -Dm 644 LICENSE.txt \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
- install -Dm 755 textext.py \
- "${pkgdir}/usr/share/inkscape/extensions/textext.py"
- install -Dm 644 textext.inx \
- "${pkgdir}/usr/share/inkscape/extensions/textext.inx"
- }
+ cd $pkgname-$pkgver-linux/extension
+ install -d "$pkgdir"/usr/share/inkscape/extensions
+ for _i in asktext.py default_packages.tex latexlogparser.py textext.{inx,py} typesetter.py win_app_paths.py
+ do install ${_i} "$pkgdir"/usr/share/inkscape/extensions/$_i
+ done
+ cd ..
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ install LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+
+}