summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-10-26 02:08:31 +0100
committerhaawda2020-10-26 02:08:31 +0100
commit07926fefd660853e35ef12ac27f2081cd618fe8c (patch)
tree455e938d2e0d4d4e8f047c49d17eb0111e06b212
parent55d61122177ee3c290f6fa83824b1349c1bec38b (diff)
downloadaur-07926fefd660853e35ef12ac27f2081cd618fe8c.tar.gz
adopted again
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efec27ad2919..cb56781d11dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = textext-git
pkgdesc = An inkscape extension which lets you add LaTeX equations to your drawings
- pkgver = 0.9.0.8.g0a4b388
+ pkgver = 1.2.0
pkgrel = 1
epoch = 1
url = https://github.com/textext/textext.git
@@ -8,14 +8,8 @@ pkgbase = textext-git
license = custom:BSD
makedepends = mercurial
depends = inkscape
- depends = python2
+ depends = python
depends = texlive-core
- optdepends = pygtk
- optdepends = python2-lxml
- optdepends = pdf2svg
- optdepends = pstoedit
- optdepends = ghostscript
- optdepends = imagemagick6
provides = textext
conflicts = textext
source = git+https://github.com/textext/textext.git
diff --git a/PKGBUILD b/PKGBUILD
index 2e825941cefd..abee00607c8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=textext-git
-pkgver=0.9.0.8.g0a4b388
+pkgver=1.2.0
epoch=1
pkgrel=1
pkgdesc="An inkscape extension which lets you add LaTeX equations to your drawings"
@@ -12,8 +12,7 @@ url="https://github.com/textext/textext.git"
provides=('textext')
conflicts=('textext')
makedepends=('mercurial')
-depends=('inkscape' 'python2' 'texlive-core')
-optdepends=('pygtk' 'python2-lxml' 'pdf2svg' 'pstoedit' 'ghostscript' 'imagemagick6')
+depends=('inkscape' 'python' 'texlive-core')
source=("git+$url")
md5sums=('SKIP')
@@ -23,15 +22,10 @@ pkgver() {
}
package() {
- install -d "$pkgdir"/usr/share/inkscape/extensions
- cd ${pkgname%-git}/extension
- cp -r ${pkgname%-git} "$pkgdir"/usr/share/inkscape/extensions
- install -m644 ${pkgname%-git}.inx "$pkgdir"/usr/share/inkscape/extensions/
- cd ..
- install -d "$pkgdir"/usr/share/licenses/$pkgname
- install LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
- cd "$pkgdir"/usr/share/inkscape/extensions/${pkgname%-git}
- sed -i '1s+\#!/usr/bin/env python+\#!/usr/bin/env python2+' __init__.py typesetter.py
+ cd ${pkgname%-git}
+ python setup.py --inkscape-extensions-path="$pkgdir"/usr/share/inkscape/extensions/
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ rm -rf "$pkgdir/usr/share/inkscape/extensions/textext/__pycache__"
}